Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 790713 - x11-misc/sddm-0.20.0: future version bump
Summary: x11-misc/sddm-0.20.0: future version bump
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: LxQt maintainers
URL: https://github.com/sddm/sddm/mileston...
Whiteboard:
Keywords: LATER
: 832635 838931 859868 865913 872641 880541 893176 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-05-17 18:08 UTC by Perfect Gentleman
Modified: 2023-02-04 13:47 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Perfect Gentleman 2021-05-17 18:08:22 UTC
https://github.com/sddm/sddm/releases/tag/v0.19.0

Reproducible: Always
Comment 1 Andreas Sturmlechner gentoo-dev 2021-05-17 19:34:32 UTC
That release is broken, but yes, I'm on it. Sorry for the delays.

*** This bug has been marked as a duplicate of bug 753104 ***
Comment 2 Andreas Sturmlechner gentoo-dev 2022-04-17 15:20:26 UTC
*** Bug 832635 has been marked as a duplicate of this bug. ***
Comment 3 Andreas Sturmlechner gentoo-dev 2022-04-17 15:22:02 UTC
*** Bug 838931 has been marked as a duplicate of this bug. ***
Comment 4 Andreas Sturmlechner gentoo-dev 2022-07-22 10:38:37 UTC
*** Bug 859868 has been marked as a duplicate of this bug. ***
Comment 5 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-08-21 08:46:48 UTC
*** Bug 865913 has been marked as a duplicate of this bug. ***
Comment 6 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-09-24 09:41:25 UTC
*** Bug 872641 has been marked as a duplicate of this bug. ***
Comment 7 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-11-08 22:06:55 UTC
*** Bug 880541 has been marked as a duplicate of this bug. ***
Comment 8 Andreas Sturmlechner gentoo-dev 2023-02-04 10:12:59 UTC
*** Bug 893176 has been marked as a duplicate of this bug. ***
Comment 9 Larry the Git Cow gentoo-dev 2023-02-04 13:00:39 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/qt.git/commit/?id=874d04dd36d01a9bb6f07d2bad6427c7b6883cbb

commit 874d04dd36d01a9bb6f07d2bad6427c7b6883cbb
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2023-02-04 11:22:59 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2023-02-04 12:56:46 +0000

    x11-misc/sddm: Adapt to upstream changes for 0.20.0 release prep
    
    - Set QTMIN to 5.15.2
    
    - Switch SDDM configuration to /etc/sddm.conf.d/
      - New Gentoo defaults file: 01gentoo.conf
      - For IUSE="elogind", fix path to /bin/loginctl
    
    - Don't look for pam_systemd.so by default
    - Respin pam-1.4 substack patch, dropping upstreamed changes
    - Respin *-respect-user-flags.patch for minimal context
    
    See also: https://github.com/gentoo/gentoo/pull/18935
    See also: https://github.com/gentoo/gentoo/pull/25853
    
    Bug: https://bugs.gentoo.org/669980
    Bug: https://bugs.gentoo.org/728550
    Bug: https://bugs.gentoo.org/790713
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 x11-misc/sddm/files/pam-1.4-substack.patch         | 31 ---------
 .../files/sddm-0.18.1-respect-user-flags.patch     | 25 --------
 .../sddm-0.20.0-disable-etc-debian-check.patch     | 26 ++++++++
 ...sddm-0.20.0-no-default-pam_systemd-module.patch | 43 +++++++++++++
 .../files/sddm-0.20.0-respect-user-flags.patch     | 11 ++++
 .../files/sddm-0.20.0-sddm.pam-use-substack.patch  | 37 +++++++++++
 x11-misc/sddm/sddm-9999.ebuild                     | 74 ++++++++++++++--------
 7 files changed, 166 insertions(+), 81 deletions(-)
Comment 10 Andreas Sturmlechner gentoo-dev 2023-02-04 13:47:21 UTC
Testing of sddm-9999 ebuild in qt overlay welcome, report runtime bugs upstream.