Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 789624 - net-wireless/uhd-3.15.0.0-r100 - /.../dma_fifo_block_ctrl_impl.cpp: error: _1 was not declared in this scope (maybe gcc-11 related)
Summary: net-wireless/uhd-3.15.0.0-r100 - /.../dma_fifo_block_ctrl_impl.cpp: error: _1...
Status: RESOLVED DUPLICATE of bug 727766
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Rick Farina (Zero_Chaos)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-05-12 09:06 UTC by Toralf Förster
Modified: 2021-05-25 12:13 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.87 KB, text/plain)
2021-05-12 09:06 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,170.37 KB, text/plain)
2021-05-12 09:06 UTC, Toralf Förster
Details
environment (environment,167.25 KB, text/plain)
2021-05-12 09:06 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,25.57 KB, application/x-bzip)
2021-05-12 09:06 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,7.34 KB, application/x-bzip)
2021-05-12 09:06 UTC, Toralf Förster
Details
net-wireless:uhd-3.15.0.0-r100:20210512-003051.log (net-wireless:uhd-3.15.0.0-r100:20210512-003051.log,225.68 KB, text/plain)
2021-05-12 09:06 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,46.17 KB, application/x-bzip)
2021-05-12 09:06 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-05-12 09:06:21 UTC
/var/tmp/portage/net-wireless/uhd-3.15.0.0-r100/work/uhd-3.15.0.0/host/lib/rfnoc/dma_fifo_block_ctrl_impl.cpp: In constructor ‘dma_fifo_block_ctrl_impl::dma_fifo_block_ctrl_impl(const uhd::rfnoc::make_args_t&)’:
/var/tmp/portage/net-wireless/uhd-3.15.0.0-r100/work/uhd-3.15.0.0/host/lib/rfnoc/dma_fifo_block_ctrl_impl.cpp:61:21: error: ‘_1’ was not declared in this scope
   61 |                     _1,
      |                     ^~
/var/tmp/portage/net-wireless/uhd-3.15.0.0-r100/work/uhd-3.15.0.0/host/lib/rfnoc/dma_fifo_block_ctrl_impl.cpp:61:21: note: suggested alternatives:
In file included from /usr/include/boost/mpl/aux_/include_preprocessed.hpp:37,

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1-j2-20210510-164358

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-11.1.0 *
clang version 12.0.0
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/12/bin
/usr/lib/llvm/12
12.0.0
Python 3.8.10
Available Ruby profiles:
  [1]   ruby26 (with Rubygems)
  [2]   ruby30 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.52.1 *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.292_p10 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.10.4

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Tue May 11 23:50:56 UTC 2021

emerge -qpvO net-wireless/uhd
[ebuild  N    ] net-wireless/uhd-3.15.0.0-r100  USE="b100 b200 mpmd n230 usb usrp1 usrp2 utils x300 -doc -e300 -examples -octoclock -test" PYTHON_SINGLE_TARGET="python3_8 -python3_7 -python3_9"
Comment 1 Toralf Förster gentoo-dev 2021-05-12 09:06:22 UTC
Created attachment 707379 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-05-12 09:06:24 UTC
Created attachment 707382 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2021-05-12 09:06:26 UTC
Created attachment 707385 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2021-05-12 09:06:27 UTC
Created attachment 707388 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2021-05-12 09:06:28 UTC
Created attachment 707391 [details]
logs.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2021-05-12 09:06:29 UTC
Created attachment 707394 [details]
net-wireless:uhd-3.15.0.0-r100:20210512-003051.log
Comment 7 Toralf Förster gentoo-dev 2021-05-12 09:06:31 UTC
Created attachment 707397 [details]
temp.tar.bz2
Comment 8 David Seifert gentoo-dev 2021-05-25 12:13:30 UTC

*** This bug has been marked as a duplicate of bug 727766 ***