Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 788874 - media-video/obs-studio-26.1.2-r1: obs-studio-26.1.2-python-3.8.patch does not compile with musl
Summary: media-video/obs-studio-26.1.2-r1: obs-studio-26.1.2-python-3.8.patch does not...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Chiitoo
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-08 06:29 UTC by 12101111
Modified: 2021-05-08 14:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 12101111 2021-05-08 06:29:00 UTC
musl don't support RTLD_DEEPBIND

Reproducible: Always

Steps to Reproduce:
1.compile media-video/obs-studio-26.1.2-r1 on musl
2.failed to compile it
Actual Results:  
../obs-studio-26.1.2/libobs/util/platform-nix.c:77:19: error: use of undeclared identifier 'RTLD_DEEPBIND'                           RTLD_LAZY | RTLD_DEEPBIND | RTLD_GLOBAL);                                       ^1 error generated.