Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 788580 - media-radio/flrig-1.3.54 - main.cxx: error: streampos is not a member of std::ostringstream {aka std::_cxx11::basic_ostringstream< (maybe gcc-11 related)
Summary: media-radio/flrig-1.3.54 - main.cxx: error: streampos is not a member of std:...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Thomas Beierlein
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-05-06 07:52 UTC by Toralf Förster
Modified: 2021-09-23 20:26 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,20.12 KB, text/plain)
2021-05-06 07:52 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,450.67 KB, text/plain)
2021-05-06 07:52 UTC, Toralf Förster
Details
environment (environment,69.70 KB, text/plain)
2021-05-06 07:52 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,31.96 KB, application/x-bzip)
2021-05-06 07:52 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,9.08 KB, application/x-bzip)
2021-05-06 07:52 UTC, Toralf Förster
Details
media-radio:flrig-1.3.54:20210506-030204.log (media-radio:flrig-1.3.54:20210506-030204.log,15.23 KB, text/plain)
2021-05-06 07:52 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,20.54 KB, application/x-bzip)
2021-05-06 07:52 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-05-06 07:52:33 UTC
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I.  -I. -I./include -I./xmlrpcpp  -I./xmlrpcpp -I/usr/include/fltk -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_THREAD_SAFE -D_REENTRANT -I. -I./include   -pipe -Wall -fexceptions -O2   -DNDEBUG -pipe -march=native -fno-diagnostics-color  -Og -g -c -o flrig-main.o `test -f 'main.cxx' || echo './'`main.cxx
main.cxx: In function ‘void rotate_log(std::string)’:
main.cxx:316:24: error: ‘streampos’ is not a member of ‘std::ostringstream’ {aka ‘std::__cxx11::basic_ostringstream<char>’}
  316 |         ostringstream::streampos p;
      |                        ^~~~~~~~~
main.cxx:320:9: error: ‘p’ was not declared in this scope
  320 |         p = oldfn.tellp();

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_plasma_systemd-20210421-084009

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-8.3.1
 [2] x86_64-pc-linux-gnu-11.1.0 *
clang version 12.0.0
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/12/bin
/usr/lib/llvm/12
12.0.0
Python 3.8.10
Available Ruby profiles:
  [1]   ruby26 (with Rubygems)
  [2]   ruby30 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.51.0 *
The following VMs are available for generation-2:
1)	IcedTea JDK 3.18.0 [icedtea-8]
2)	JamVM JDK 2.0.0 [jamvm]
*)	AdoptOpenJDK 8.292_p10 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-8 
  [2]   jamvm 
  [3]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.10.4

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Thu May  6 01:35:17 UTC 2021

emerge -qpvO media-radio/flrig
[ebuild  N    ] media-radio/flrig-1.3.54  USE="nls"
Comment 1 Toralf Förster gentoo-dev 2021-05-06 07:52:34 UTC
Created attachment 706323 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-05-06 07:52:36 UTC
Created attachment 706326 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2021-05-06 07:52:37 UTC
Created attachment 706329 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2021-05-06 07:52:39 UTC
Created attachment 706332 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2021-05-06 07:52:40 UTC
Created attachment 706335 [details]
logs.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2021-05-06 07:52:41 UTC
Created attachment 706338 [details]
media-radio:flrig-1.3.54:20210506-030204.log
Comment 7 Toralf Förster gentoo-dev 2021-05-06 07:52:42 UTC
Created attachment 706341 [details]
temp.tar.bz2
Comment 8 Thomas Beierlein gentoo-dev 2021-06-14 04:21:33 UTC
Bug is fixed in new flrig-1.4.0, which is in tree now.
Comment 9 Sam James archtester gentoo-dev Security 2021-06-15 01:54:53 UTC
(In reply to Thomas Beierlein from comment #8)
> Bug is fixed in new flrig-1.4.0, which is in tree now.

Thanks a bunch!
Comment 10 Thomas Beierlein gentoo-dev 2021-09-23 18:19:58 UTC
*** Bug 814497 has been marked as a duplicate of this bug. ***