Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 78711 - [EBUILD] new package: app-admin/arkeia-light
Summary: [EBUILD] new package: app-admin/arkeia-light
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High enhancement (vote)
Assignee: App-Backup Team
URL: http://www.arkeia.com
Whiteboard:
Keywords: EBUILD
Depends on: 101794
Blocks:
  Show dependency tree
 
Reported: 2005-01-19 11:28 UTC by unlord
Modified: 2006-06-05 14:45 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
arkeia-light-5.2.24.ebuild (arkeia-light-5.2.24.ebuild,1.03 KB, text/plain)
2005-01-19 11:29 UTC, unlord
Details
files/arkeia (arkeia,870 bytes, text/plain)
2005-01-19 11:29 UTC, unlord
Details
files/arkc (arkc,232 bytes, text/plain)
2005-01-19 11:29 UTC, unlord
Details
files/xarkeia (xarkeia,235 bytes, text/plain)
2005-01-19 11:30 UTC, unlord
Details
arkeia-light-5.2.24.ebuild (arkeia-light-5.2.24.ebuild,1.00 KB, text/plain)
2005-01-19 11:49 UTC, unlord
Details
licenses/Arkeia (Arkeia,13.66 KB, text/plain)
2005-07-26 16:08 UTC, Arnaud Spicht
Details
arkeia-light-5.2.28.ebuild (arkeia-light-5.2.28.ebuild,966 bytes, text/plain)
2005-09-23 15:03 UTC, unlord
Details
files/99arkeia) (99arkeia,154 bytes, text/plain)
2005-10-07 11:24 UTC, Arnaud Spicht
Details
arkeia-light-5.2.28.ebuild (arkeia-light-5.2.28.ebuild,1.71 KB, text/plain)
2005-10-07 11:27 UTC, Arnaud Spicht
Details

Note You need to log in before you can comment on or make changes to this bug.
Description unlord 2005-01-19 11:28:11 UTC
Here is an ebuild for the free version of the commercial backup utility Arkeia.  It contains a gentoo compatible init script, and places all the files under the directory /opt/arkeia.  The only ugly thing is that the binarys have hardcoded the location /etc/opt/arkeia/ARKEIA_DIR as where they look for the path to the installation directory.

I am not sure, but it looks like this ebuild might need to be modified to contain the arkeia license.  The aiinfo.lst file in arkeia-light-5.2.24.tar.gz is the only place it mentions that this software is free:

  APPINFO "Network backup solution, free for 3 machines"

This should work just fine out of the box for most uses.

Reproducible: Always
Steps to Reproduce:
Comment 1 unlord 2005-01-19 11:29:06 UTC
Created attachment 48985 [details]
arkeia-light-5.2.24.ebuild
Comment 2 unlord 2005-01-19 11:29:39 UTC
Created attachment 48986 [details]
files/arkeia
Comment 3 unlord 2005-01-19 11:29:58 UTC
Created attachment 48987 [details]
files/arkc
Comment 4 unlord 2005-01-19 11:30:21 UTC
Created attachment 48988 [details]
files/xarkeia
Comment 5 unlord 2005-01-19 11:49:04 UTC
Created attachment 48989 [details]
arkeia-light-5.2.24.ebuild

Added the correct HOMEPAGE and removed the LICENSE
Comment 6 Arnaud Spicht 2005-07-26 16:08:18 UTC
Created attachment 64391 [details]
licenses/Arkeia

This is the license for all products from Arkeia corporation
Comment 7 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2005-07-27 10:18:58 UTC
Arnaud, here are some comments about the ebuild for you to look at.
KEYWORDS="~x86"
this should be '-* ~x86' as it's a binary package.

"uncompress < arktar.z | tar -xvf -"
This should work too: unpack arktar.z

"hostname > ${D}/opt/arkeia/arkeiad/admin.cfg"
This is really nasty for building binary packages that will be used on multiple 
machines. Can we move the file to /etc, and have it created in the pkg_config 
phase instead? Anything that is configuration changed by the user should be 
somewhere in /etc/, or alternatively added to CONFIG_PROTECT (discouraged, 
moving to /etc/ is better).

/etc/opt/arkeia/
any specific reason for /etc/opt/arkeia/ instead of /etc/arkeia/ ?

cp -a ${FILESDIR}/arkeia ${D}/etc/init.d/
use 'doinitd' instead.

Comment 8 Ingo Kemper 2005-09-18 15:55:47 UTC
Works perfectly on AMD64 (renamed to arkeia-light-5.2.28.ebuild, keyword ~amd64
added), thanks.

emerge info:
Portage 2.0.51.22-r2 (default-linux/amd64/2005.0, gcc-3.4.4, glibc-2.3.5-r1,
2.6.13.1 x86_64)
=================================================================
System uname: 2.6.13.1 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.6.13
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.1-r1
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -march=athlon64 -funroll-all-loops -funit-at-a-time -fpeel-loops
-ftracer -funswitch-loops "
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/lib64/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=athlon64 -funroll-all-loops -funit-at-a-time -fpeel-loops
-ftracer -funswitch-loops "
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://rsync.klinchem.med.tu-muenchen.de/
ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
ftp://mirrors.sec.informatik.tu-darmstadt.de/gentoo/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/
http://ftp.du.se/pub/os/gentoo
http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/
http://mirror.datapipe.net/gentoo http://128.213.5.34/gentoo/
http://gentoo.ynet.sk/pub http://ftp.easynet.nl/mirror/gentoo/"
LANG="de_DE@euro"
LINGUAS="de en"
MAKEOPTS="-j2"
PKGDIR="/usr/local/packets"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage-de /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="amd64 X Xaw3d alsa apache2 avi bash-completion berkdb bitmap-fonts bonobo
bootsplash cdr crypt cups curl dbus dga doc dvd dvdr dvdread editor eds emboss
encode esd ext fam fbcon flac flash foomaticdb fortran gd gdbm gif gimpprint
gnome gnomedb gnuplot gphoto2 gpm gstreamer gtk gtk2 gtkhtml hal hbci
imagemagick imlib ipv6 java joystick jpeg junit lcms ldap libwww live lzo lzw
lzw-tiff mad mailwrapper matroska mng motif mozcalendar mozilla mozsvg mp3 mpeg
mpeg4 mysql mythtv nagios-dns nagios-ntp nagios-ping nagios-ssh ncurses nls nntp
nptl nptlonly nvidia offensive ogg oggvorbis opengl oss pam pda pdflib perl
plotutils png ppds python quicktime readline real rtc samba scanner sdl sms
spell ssl svg tcltk tcpd tetex theora tiff transcode truetype truetype-fonts
type1 type1-fonts unicode usb userlocales utf8 v4l v4l2 vcdimager vorbis wmf
xanim xface xine xml xml2 xmms xpm xprint xv xvid xvmc zlib zvbi linguas_de
linguas_en userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LC_ALL, LDFLAGS
Comment 9 unlord 2005-09-23 15:03:50 UTC
Created attachment 69118 [details]
arkeia-light-5.2.28.ebuild

Here is a newer version of the ebuild.	This takes into account some of the
changes suggested here, specifically:

- bumped the version
- changed the keywords to "-* ~x86 ~amd64"
- using doinitd to install 'arkeia' script
- using dobin to install 'arkc' and 'xarkeia' scripts

I am still waiting to hear back from Arnaud regarding the license he attached. 
I have skimmed it and didn't see any language in it that explicitly allowed the
product to be used for free under linux.

Other suggestions that were discarded:

- could not use "unpack arktar.z" since unpack looks in /usr/portage/distfiles
- could not move configuration files to /etc/arkeia since the /etc/opt/arkeia
path is hard coded (perhaps this could be fixed upstream by Arkeia folks)
Comment 10 Arnaud Spicht 2005-10-07 11:24:10 UTC
Created attachment 70106 [details]
files/99arkeia)

This file set environment variables to protect Arkeia configuration files from
being overwritten by an upgrade.
Comment 11 Arnaud Spicht 2005-10-07 11:27:32 UTC
Created attachment 70107 [details]
arkeia-light-5.2.28.ebuild

Configurations files are now in /etc/arkeia
The arkeia database is moved to /var/lib/arkeia
Comment 12 Lisa Seelye (RETIRED) gentoo-dev 2006-06-05 14:45:39 UTC
From HOMEPAGE http://www.arkeia.org/arkeialight.html:

Arkeia Light is no longer available and has been replaced by Arkeia Smart Backup. 

Arkeia Smart Backup has no client number limit and supports a broader range of backed up clients, including Linux, all versions of Windows, xBSDs, Mac OS X and Novell Netware. It allows the option of backup to a single tape drive as well as support for tape autoloaders and backup to disk through Arkeia's embedded Virtual tape Library. 

Arkeia Smart Backup is free up to 50 GB of data without purchasing a volume license and there is no expiration date..

--
I can't commit a package that isn't supported/offered upstream.