Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 786636 - net-analyzer/nsat-1.5-r5 fails to compile
Summary: net-analyzer/nsat-1.5-r5 fails to compile
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-04-29 05:56 UTC by Agostino Sarubbo
Modified: 2021-08-04 21:26 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,228.25 KB, text/plain)
2021-04-29 05:56 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2021-04-29 05:56:47 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: net-analyzer/nsat-1.5-r5 fails to compile.
Discovered on: amd64 (internal ref: ci)

NOTE:
This machine uses GCC-11: https://gcc.gnu.org/gcc-11/porting_to.html
If you think it is a GCC-11 related issue, please block bug 732706.
Comment 1 Agostino Sarubbo gentoo-dev 2021-04-29 05:56:50 UTC
Created attachment 703530 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2021-04-29 05:56:51 UTC
Possible context of error(s):

SockSet.cpp:(.text+0x5): undefined reference to `AuditSet::AuditSet()'
SockSet.cpp:(.text+0x44f): undefined reference to `AuditSet::plog(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x5cf): undefined reference to `AuditSet::plog(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x64f): undefined reference to `AuditSet::os()'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x65c): undefined reference to `AuditSet::bo()'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x674): undefined reference to `AuditSet::snmp()'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x68c): undefined reference to `AuditSet::nbname()'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x6c2): undefined reference to `AuditSet::http(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x6ed): undefined reference to `AuditSet::ftp(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x718): undefined reference to `AuditSet::xwin(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x743): undefined reference to `AuditSet::ircd(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x76e): undefined reference to `AuditSet::nlps(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x799): undefined reference to `AuditSet::smb(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x7c4): undefined reference to `AuditSet::pmap(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x7ef): undefined reference to `AuditSet::smtp(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x81a): undefined reference to `AuditSet::telnet(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x845): undefined reference to `AuditSet::finger(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x870): undefined reference to `AuditSet::imap(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x89b): undefined reference to `AuditSet::nntp(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x8c6): undefined reference to `AuditSet::pop3(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x8f1): undefined reference to `AuditSet::pop2(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x91c): undefined reference to `AuditSet::ssh(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x947): undefined reference to `AuditSet::nstat(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x972): undefined reference to `AuditSet::nbind(int)'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x98c): undefined reference to `AuditSet::os()'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x999): undefined reference to `AuditSet::nbname()'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x9af): undefined reference to `AuditSet::snmp()'
/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: SockSet.cpp:(.text+0x9c5): undefined reference to `AuditSet::bo()'
SockSet.cpp:(.text+0xbc5): undefined reference to `AuditSet::icmptest()'
SockSet.cpp:(.text+0xc7): undefined reference to `AuditSet::~AuditSet()'
SockSet.cpp:(.text.unlikely+0x4): undefined reference to `AuditSet::~AuditSet()'
collect2: error: ld returned 1 exit status
Comment 3 Sam James archtester gentoo-dev Security 2021-08-04 21:26:43 UTC
Can't reproduce and doesn't seem GCC 11 specific. I've also tried with -O0.

Can you?