Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 786306 - sci-libs/coinor-bcp-1.4.4 - ./.../BCP_buffer.hpp: error: ISO C++17 does not allow dynamic exception specifications
Summary: sci-libs/coinor-bcp-1.4.4 - ./.../BCP_buffer.hpp: error: ISO C++17 does not a...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
: 801052 (view as bug list)
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-04-28 07:17 UTC by Toralf Förster
Modified: 2021-08-04 23:19 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,17.77 KB, text/plain)
2021-04-28 07:17 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,372.71 KB, text/plain)
2021-04-28 07:17 UTC, Toralf Förster
Details
environment (environment,21.56 KB, text/plain)
2021-04-28 07:17 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,27.63 KB, application/x-bzip)
2021-04-28 07:17 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,9.67 KB, application/x-bzip)
2021-04-28 07:17 UTC, Toralf Förster
Details
sci-libs:coinor-bcp-1.4.4:20210428-070609.log (sci-libs:coinor-bcp-1.4.4:20210428-070609.log,13.59 KB, text/plain)
2021-04-28 07:17 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-04-28 07:17:44 UTC
rdlibtool: compile: x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I./include -Iinclude -I/usr/include/coin -I/usr/include/coin -pipe -march=native -fno-diagnostics-color -O2 -DBCP_BUILD -c CG/BCP_cg_user.cpp -DPIC -fPIC -o .libs/BCP_cg_user.o
In file included from CG/BCP_cg_user.cpp:6:
./include/BCP_buffer.hpp:104:44: error: ISO C++17 does not allow dynamic exception specifications
  104 |    inline void set_position(const int pos) throw(BCP_fatal_error) {
      |                                            ^~~~~
./include/BCP_buffer.hpp:110:38: error: ISO C++17 does not allow dynamic exception specifications
  110 |    inline void set_size(const int s) throw(BCP_fatal_error) {

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_systemd-20210419-131016

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.1
 [2] x86_64-pc-linux-gnu-10.3.0
 [3] x86_64-pc-linux-gnu-11.1.0 *
clang version 12.0.0
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/12/bin
/usr/lib/llvm/12
12.0.0
Python 3.8.9
Available Ruby profiles:
  [1]   ruby26 (with Rubygems)
  [2]   ruby30 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.51.0
  [2]   rust-1.51.0 *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.292_p10 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.10.4

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Wed Apr 28 06:50:18 UTC 2021

emerge -qpvO sci-libs/coinor-bcp
[ebuild  N    ] sci-libs/coinor-bcp-1.4.4  USE="-doc -test"
Comment 1 Toralf Förster gentoo-dev 2021-04-28 07:17:45 UTC
Created attachment 703161 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-04-28 07:17:46 UTC
Created attachment 703164 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2021-04-28 07:17:48 UTC
Created attachment 703167 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2021-04-28 07:17:49 UTC
Created attachment 703170 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2021-04-28 07:17:50 UTC
Created attachment 703173 [details]
logs.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2021-04-28 07:17:51 UTC
Created attachment 703176 [details]
sci-libs:coinor-bcp-1.4.4:20210428-070609.log
Comment 7 Larry the Git Cow gentoo-dev 2021-08-04 23:17:56 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=915f56b619b4b9748abd815ab846adae9e17b382

commit 915f56b619b4b9748abd815ab846adae9e17b382
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-08-04 23:16:53 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-08-04 23:17:47 +0000

    sci-libs/coinor-bcp: fix build with GCC 11
    
    Closes: https://bugs.gentoo.org/786306
    Signed-off-by: Sam James <sam@gentoo.org>

 sci-libs/coinor-bcp/coinor-bcp-1.4.4.ebuild        |  4 +++
 .../files/coinor-bcp-1.4.4-gcc11-exceptions.patch  | 36 ++++++++++++++++++++++
 2 files changed, 40 insertions(+)
Comment 8 Sam James archtester gentoo-dev Security 2021-08-04 23:19:23 UTC
*** Bug 801052 has been marked as a duplicate of this bug. ***