Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 786240 - media-plugins/vdr-mp3ng-0.0.1_pre5-r3 - data-mp3.c: error: ordered comparison of pointer with integer zero (char* and int)
Summary: media-plugins/vdr-mp3ng-0.0.1_pre5-r3 - data-mp3.c: error: ordered comparison...
Status: RESOLVED DUPLICATE of bug 740274
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo VDR Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-04-28 07:07 UTC by Toralf Förster
Modified: 2021-05-11 18:48 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,17.73 KB, text/plain)
2021-04-28 07:07 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,360.08 KB, text/plain)
2021-04-28 07:07 UTC, Toralf Förster
Details
environment (environment,96.72 KB, text/plain)
2021-04-28 07:07 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,27.52 KB, application/x-bzip)
2021-04-28 07:07 UTC, Toralf Förster
Details
media-plugins:vdr-mp3ng-0.0.1_pre5-r3:20210427-233032.log (media-plugins:vdr-mp3ng-0.0.1_pre5-r3:20210427-233032.log,34.75 KB, text/plain)
2021-04-28 07:07 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,27.66 KB, application/x-bzip)
2021-04-28 07:07 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-04-28 07:07:37 UTC
x86_64-pc-linux-gnu-g++ -pipe -march=native -fno-diagnostics-color  -O2 -fPIC -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -std=gnu++03 -std=gnu++03 -c -DCONFDIR=\"/etc/vdr\" -D_GNU_SOURCE -DVDRVERSNUM=20406 -DHAVE_IMLIB2 -DHAVE_SNDFILE -I/usr/include -I/usr/include  data-mp3.c
data-mp3.c: In member function ‘virtual bool cPlayList::Load()’:
data-mp3.c:229:41: error: ordered comparison of pointer with integer zero (‘char*’ and ‘int’)
  229 |     while(fgets(buffer,sizeof(buffer),f)>0) {
      |           ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~
data-mp3.c: In member function ‘const char* cPlayList::AddExt(const char*, const char*)’:
data-mp3.c:316:11: warning: ignoring return value of ‘int asprintf(char**, const char*, ...)’ declared with attribute ‘warn_unused_result’ [-Wunused-result]

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_systemd-20210419-131016

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.1
 [2] x86_64-pc-linux-gnu-10.3.0
 [3] x86_64-pc-linux-gnu-11.1.0 *
clang version 12.0.0
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/12/bin
/usr/lib/llvm/12
12.0.0
Python 3.8.9
Available Ruby profiles:
  [1]   ruby26 (with Rubygems)
  [2]   ruby30 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.51.0
  [2]   rust-1.51.0 *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.292_p10 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.10.4

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Tue Apr 27 23:05:14 UTC 2021

emerge -qpvO media-plugins/vdr-mp3ng
[ebuild  N    ] media-plugins/vdr-mp3ng-0.0.1_pre5-r3  USE="-oss -vorbis"
Comment 1 Toralf Förster gentoo-dev 2021-04-28 07:07:39 UTC
Created attachment 702795 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-04-28 07:07:40 UTC
Created attachment 702798 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2021-04-28 07:07:42 UTC
Created attachment 702801 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2021-04-28 07:07:43 UTC
Created attachment 702804 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2021-04-28 07:07:45 UTC
Created attachment 702807 [details]
media-plugins:vdr-mp3ng-0.0.1_pre5-r3:20210427-233032.log
Comment 6 Toralf Förster gentoo-dev 2021-04-28 07:07:46 UTC
Created attachment 702810 [details]
temp.tar.bz2
Comment 7 Joerg Bornkessel gentoo-dev 2021-05-11 18:48:29 UTC
Not gcc-11 or clang depended
yust very old stupid code...

*** This bug has been marked as a duplicate of bug 740274 ***