Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 78551 - Test sound works in control center but kde apps have no sound
Summary: Test sound works in control center but kde apps have no sound
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2005-01-18 11:07 UTC by Martin Tsachev
Modified: 2005-05-12 12:04 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Martin Tsachev 2005-01-18 11:07:27 UTC
I can do test sound and I hear the KDE start up sound but when trying to set sound notification for any kde app it doesn't play anything. Nothing is logged on vt1 and I tried to start kteatime from a console and no errors are dumped when trying to play sounds.

Reproducible: Always
Steps to Reproduce:

emerge info
Portage 2.0.51-r3 (default-linux/x86/2004.3, gcc-3.3.5, unavailable, 2.6.10-
gentoo-r4-p4.3 i686)
System uname: 2.6.10-gentoo-r4-p4.3 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Libtools: sys-devel/libtool-1.5.2-r7
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.
3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /
usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/init.d /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
FEATURES="autoaddcvs ccache distlocks sandbox"
USE="X acpi alsa apache2 arts avi bash-completion bluetooth crypt encode gdbm 
gif imlib jpeg kde libg++ libwww mmx mmx2 mpeg ncurses nptl oggvorbis opengl oss 
pam pdflib png python qt readline sdl slang spell sse sse2 ssl truetype vhosts 
xml2 xv zlib"
Comment 1 Michiel de Bruijne 2005-01-18 17:07:40 UTC
Have tried anything to solve this by yourself?, searched/posted something on the forums or gentoo user-list?, what version of kde?, what's the content of ~/.kde/share/config/knotifyrc?, etc.

Please try a little harder to solve your problem with the Gentoo community before adding extra load to the devs. If you already have done this and you are convinced there is a bug in the kde-package, then post your tests and results here and I will try to help you.
Comment 2 Martin Tsachev 2005-01-19 01:45:43 UTC
It's not that I didn't google for that, it's just that I just got people with not enough permissions or muted cards. The key was knotifyrc which gets trashed for some reason after upgrading KDE. I'm using 3.3.2 btw. I haven't had issues like this before with Mandrake/NetBSD/Slackware/Debian/FreeBSD upgrading KDE and sound so I thought it might be something Gentoo specific.
Comment 3 Gregorio Guidi (RETIRED) gentoo-dev 2005-05-12 09:55:39 UTC
Is it still an issue?
Comment 4 Martin Tsachev 2005-05-12 10:08:44 UTC
No, I edited knotifyrc and it works fine now.
Comment 5 Gregorio Guidi (RETIRED) gentoo-dev 2005-05-12 12:04:42 UTC
After a quick search, it seems this wasn't a gentoo issue anyway:
it could be either or