Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 782427 - net-misc/nextcloud-client fails to sync directories and files with non-ascii characters
Summary: net-misc/nextcloud-client fails to sync directories and files with non-ascii ...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Bernard Cafarelli
Depends on:
Reported: 2021-04-12 09:04 UTC by Stefan Radermacher
Modified: 2022-03-10 12:36 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

Nextcloud log file (nextcloud.log,3.05 KB, text/x-log)
2022-02-14 17:40 UTC, Stefan Radermacher

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Radermacher 2021-04-12 09:04:14 UTC
The Nextcloud client encounters an error when it should sync a directory or file with non-ascii characters in its name and then halts synchronization for other files.

Reproducible: Always

Steps to Reproduce:
1. Create a file or directory with non-ascii character (such as a German umlaut) in its name in a synchronized directory.
2. Nextcloud client encounters error
3. Nextcloud client halts synchronization

This issue occurred in conjunction with the issue encountered in Bug 765430. Comment 17 in that bug lists a solution that was found in KIO upstream
Comment 1 Bernard Cafarelli gentoo-dev 2022-02-14 08:53:12 UTC
I re-tested with 3.4.2 (and current ICU), non-ascii unicode characters worked fine for synced directories and files - I tried with a sampling of chars from

So I think this one should be good now, don't hesitate to reopen if issue still happens
Comment 2 Stefan Radermacher 2022-02-14 09:57:23 UTC
OK, I just tested again, with net-misc/nextcloud-client-3.4.2 and dev-libs/icu-70.1-r1, and it's still not working.

I created "Test für Umlaut" and then "Test fuer Umlaut" in my synced Nextcloud directory. The latter was correctly synchronized, while the former was completely ignored, the file also does not get the greem mark in Dolphin that all the others have.

Does the nextcloud-client perhaps create any logs that could be helpful?
Comment 3 Bernard Cafarelli gentoo-dev 2022-02-14 12:25:39 UTC
Thanks for the quick answer and test!

In the app preferences, there is "create a debug archive" option, it gets logs from ~/.config/Nextcloud/logs, so you can probably check them directly there (still called owncloud* here hehe: 20220214_1130_owncloud.log.0)

One possible difference with my test is that I do not use dolphin - this was done directly with the nextcloud binary, adding a test folder to sync. Maybe the issue is in the dolphin extension and not in the binary itself?
Comment 4 Stefan Radermacher 2022-02-14 17:39:51 UTC
Dolphin  is not actually involved in any syncing, it just displays the files.

I created a File called "Ümlaut" to see what happens in the log. I have appended what I think is the relevant part of the log.

There is some German in there: "Der Dateiname kann auf Ihrem Dateisystem nicht entschlüsselt werden." means "The filenam cannot be decoded on your file system" – which is weird, since the file is right there in my filesystem (which is ext4).
Comment 5 Stefan Radermacher 2022-02-14 17:40:16 UTC
Created attachment 765103 [details]
Nextcloud log file