Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 782097 - app-crypt/scute-1.6.0 - /.../ld: cannot find -lte
Summary: app-crypt/scute-1.6.0 - /.../ld: cannot find -lte
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: David Seifert
URL: https://dev.gnupg.org/T5394
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: slibtool
  Show dependency tree
 
Reported: 2021-04-11 12:12 UTC by Toralf Förster
Modified: 2021-08-19 03:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,17.04 KB, text/plain)
2021-04-11 12:12 UTC, Toralf Förster
Details
app-crypt:scute-1.6.0:20210411-085839.log (app-crypt:scute-1.6.0:20210411-085839.log,122.14 KB, text/plain)
2021-04-11 12:12 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,385.86 KB, text/plain)
2021-04-11 12:12 UTC, Toralf Förster
Details
environment (environment,21.13 KB, text/plain)
2021-04-11 12:12 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,14.31 KB, application/x-bzip)
2021-04-11 12:12 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,9.20 KB, application/x-bzip)
2021-04-11 12:12 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,12.68 KB, application/x-bzip)
2021-04-11 12:12 UTC, Toralf Förster
Details
Patch against the upstream git. (scute-libtool.patch,2.37 KB, patch)
2021-04-11 22:23 UTC, orbea
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-04-11 12:12:47 UTC
rdlibtool: lconf: found "/var/tmp/portage/app-crypt/scute-1.6.0/work/scute-1.6.0/libtool".
rdlibtool: link: x86_64-pc-linux-gnu-gcc t-link.o -Wall -Wno-pointer-sign -Wpointer-arith -O2 -pipe -march=native -fno-diagnostics-color -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0 -Wl,-rpath -Wl,/usr/lib64/pkcs11 -L../src/.libs -lte -L/usr/lib64 -lassuan -lgpg-error -o .libs/t-link
/usr/lib/gcc/x86_64-pc-linux-gnu/10.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lte
collect2: error: ld returned 1 exit status
rdlibtool: exec error upon slbt_exec_link_create_executable(), line 1731: (see child process error messages).
rdlibtool: < returned to > slbt_exec_link(), line 2051.

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no-multilib_hardened-20210401-181817

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.1
 [2] x86_64-pc-linux-gnu-8.3.1
 [3] x86_64-pc-linux-gnu-10.3.0 *
clang version 11.1.0
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/11/bin
/usr/lib/llvm/11
11.1.0
Python 3.8.9
Available Ruby profiles:
  (none found)
Available Rust versions:
  [1]   rust-bin-1.51.0
  [2]   rust-1.51.0 *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.282_p08 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.10.4

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Sun Apr 11 08:20:36 UTC 2021

emerge -qpvO app-crypt/scute
[ebuild  N    ] app-crypt/scute-1.6.0
Comment 1 Toralf Förster gentoo-dev 2021-04-11 12:12:48 UTC
Created attachment 699231 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-04-11 12:12:49 UTC
Created attachment 699234 [details]
app-crypt:scute-1.6.0:20210411-085839.log
Comment 3 Toralf Förster gentoo-dev 2021-04-11 12:12:51 UTC
Created attachment 699237 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2021-04-11 12:12:52 UTC
Created attachment 699240 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2021-04-11 12:12:54 UTC
Created attachment 699243 [details]
etc.portage.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2021-04-11 12:12:55 UTC
Created attachment 699246 [details]
logs.tar.bz2
Comment 7 Toralf Förster gentoo-dev 2021-04-11 12:12:56 UTC
Created attachment 699249 [details]
temp.tar.bz2
Comment 8 orbea 2021-04-11 22:23:31 UTC
Created attachment 699318 [details, diff]
Patch against the upstream git.

They are failing to use conventional library names which results in unexpected behavior in slibtool, but regardless the build should be fixed since its wrong.

The patch also applies against the new 1.7.0 ebuild (Which has a gcc10 regression).
Comment 9 orbea 2021-04-11 22:54:58 UTC
slibtool issue for the misleading error message.

https://dev.midipix.org/cross/slibtool/issue/44
Comment 10 orbea 2021-04-12 16:09:48 UTC
Bug report + patch for the scute upstream.

https://dev.gnupg.org/T5394
Comment 11 Sam James archtester gentoo-dev Security 2021-08-19 03:06:25 UTC
While the linked bug turned into a little bit of a.. "general discussion", midipix mentions in the bug that it works with latest slibtool, so closing.

(https://dev.gnupg.org/T5394#145306)