Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 781878 - metadata/install-qa-check.d/60python-pyc mismatch with python-utils-r1 EAPI availability
Summary: metadata/install-qa-check.d/60python-pyc mismatch with python-utils-r1 EAPI a...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-09 23:03 UTC by Casey Avila
Modified: 2021-04-10 04:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Casey Avila 2021-04-09 23:03:39 UTC
Upon a re-emerge of virtual/libusb due to the new RISC-V abi USE flags, an error regarding the `python-utils-r1` ECLASS occurs. I don't see this anywhere in the ebuild, so I am not sure what the cause of this issue is. Interestingly, this error happens after the "installation" is completed.

>>> Emerging (1 of 1) virtual/libusb-1-r2::gentoo
>>> Unpacking source...
>>> Source unpacked in /var/tmp/portage/virtual/libusb-1-r2/work
>>> Preparing source in /var/tmp/portage/virtual/libusb-1-r2/work ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/virtual/libusb-1-r2/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/virtual/libusb-1-r2/work ...
>>> Source compiled.
>>> Test phase [not enabled]: virtual/libusb-1-r2

>>> Install virtual/libusb-1-r2 into /var/tmp/portage/virtual/libusb-1-r2/image/
>>> Completed installing virtual/libusb-1-r2 into /var/tmp/portage/virtual/libusb-1-r2/image/

 * Final size of build directory: 4 KiB
 * Final size of installed tree:  4 KiB

 * ERROR: virtual/libusb-1-r2::gentoo failed:
 *   Unsupported EAPI=5 (too old) for python-utils-r1
 *
 * Call stack:
 *        misc-functions.sh, line 596:  Called install_qa_check
 *        misc-functions.sh, line 132:  Called source 'install_symlink_html_docs'
 *             60python-pyc, line   8:  Called inherit 'install_hooks'
 *                ebuild.sh, line 314:  Called __qa_source '/var/db/repos/gentoo/metadata/install-qa-check.d/60python-pyc'
 *                ebuild.sh, line 112:  Called source 'python-utils-r1'
 *   python-utils-r1.eclass, line  23:  Called die
 * The specific snippet of code:
 *   	[0-5]) die "Unsupported EAPI=${EAPI:-0} (too old) for ${ECLASS}" ;;
 *
 * If you need support, post the output of `emerge --info '=virtual/libusb-1-r2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=virtual/libusb-1-r2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/virtual/libusb-1-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/virtual/libusb-1-r2/temp/environment'.
 * Working directory: '/var/tmp/portage/virtual/libusb-1-r2/image'
 * S: '/var/tmp/portage/virtual/libusb-1-r2/work/libusb-1'
Comment 1 Casey Avila 2021-04-09 23:05:26 UTC
Portage 3.0.17 (python 3.8.8-final-0, default/linux/amd64/17.1/hardened, gcc-10.2.0, glibc-2.32-r7, 5.10.27-gentoo x86_64)
=================================================================
System uname: Linux-5.10.27-gentoo-x86_64-AMD_Ryzen_5_1600X_Six-Core_Processor-with-glibc2.2.5
KiB Mem:    16406840 total,    481644 free
KiB Swap:    8388604 total,   8386812 free
Timestamp of repository gentoo: Fri, 09 Apr 2021 22:30:01 +0000
Head commit of repository gentoo: 63cb2ebe3a5725da13e43d5b3c367d53755dccae
Timestamp of repository brother-overlay: Wed, 31 Mar 2021 12:54:50 +0000
Head commit of repository brother-overlay: 717a4d4d71a22e400a89907c6dbf5725bd42bf96

Timestamp of repository guru: Fri, 09 Apr 2021 22:07:34 +0000
Head commit of repository guru: 3cb5512b26e687c39fba7f886dcaf4bd5ef55a38

Timestamp of repository haskell: Fri, 09 Apr 2021 06:04:57 +0000
Head commit of repository haskell: b5fa483c5eac88a187690e2ce6eef516dd52f541

Timestamp of repository ricerlay: Fri, 09 Apr 2021 22:07:33 +0000
Head commit of repository ricerlay: 40e89f097d5c0a2a74752005fac93bc8d7c1f56f

sh bash 5.0_p18
ld GNU ld (Gentoo 2.35.1 p2) 2.35.1
ccache version 4.2 [enabled]
app-shells/bash:          5.0_p18::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.30.3::gentoo
dev-lang/python:          3.8.8::gentoo, 3.9.2::gentoo
dev-lang/rust:            1.47.0-r2::gentoo
dev-util/ccache:          4.2::gentoo
dev-util/cmake:           3.18.5::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1-r1::gentoo
sys-apps/sandbox:         2.20::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.2-r1::gentoo
sys-devel/binutils:       2.35.1-r1::gentoo
sys-devel/gcc:            10.2.0-r5::gentoo
sys-devel/gcc-config:     2.3.3::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.32-r7::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 24

brother-overlay
    location: /var/db/repos/brother-overlay
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/brother-overlay.git
    masters: gentoo

guru
    location: /var/db/repos/guru
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/guru.git
    masters: gentoo

haskell
    location: /var/db/repos/haskell
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/haskell.git
    masters: gentoo

kc
    location: /var/db/repos/kc
    masters: gentoo

ricerlay
    location: /var/db/repos/ricerlay
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/ricerlay.git
    masters: gentoo

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=znver1 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=znver1 -O2 -pipe"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=znver1 -O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=znver1 -O2 -pipe"
GENTOO_MIRRORS="http://www.gtlib.gatech.edu/pub/gentoo https://gentoo.osuosl.org/ https://mirrors.rit.edu/gentoo/ http://gentoo.mirrors.tds.net/gentoo http://gentoo.cs.utah.edu/"
LANG="es_MX.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j12"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl alsa amd64 bluetooth bzip2 crypt cuda elogind hardened iconv ipv6 libglvnd libtirpc multilib ncurses nls nptl openmp pam pcre pie pulseaudio readline seccomp split-usr ssl ssp unicode vdpau xattr xtpax zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sha sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_8" PYTHON_TARGETS="python3_8" RUBY_TARGETS="ruby26" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RUSTFLAGS
Comment 2 Larry the Git Cow gentoo-dev 2021-04-09 23:17:42 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1137a7ecce67c48fc9a69ab320c6156c40366122

commit 1137a7ecce67c48fc9a69ab320c6156c40366122
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-04-09 23:16:26 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-04-09 23:16:26 +0000

    metadata/install-qa-check.d: disable non-applicable QA checks for EAPI 5
    
    Fixes: bdcfb21ca5a84567e9c9d6a456374a05e798f78e
    Closes: https://bugs.gentoo.org/781878
    Signed-off-by: Sam James <sam@gentoo.org>

 metadata/install-qa-check.d/60python-pyc | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
Comment 3 Brian Evans Gentoo Infrastructure gentoo-dev 2021-04-09 23:18:45 UTC
Already fixed, but assigned to correct group
Comment 4 Larry the Git Cow gentoo-dev 2021-04-09 23:21:05 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9ffe4afadb55fc12c58131c9d3fdfb0199c5d13f

commit 9ffe4afadb55fc12c58131c9d3fdfb0199c5d13f
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-04-09 23:19:59 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-04-09 23:19:59 +0000

    python-utils-r1.eclass: add note when dropping EAPI support
    
    We need to remember to update metadata/install-qa-check.d/60python-pyc
    in future to disable now non-applicable QA checks.
    
    If we don't, we end up breaking older EAPI installs in general.
    
    See: 1137a7ecce67c48fc9a69ab320c6156c40366122
    See: bdcfb21ca5a84567e9c9d6a456374a05e798f78e
    Bug: https://bugs.gentoo.org/704286
    Bug: https://bugs.gentoo.org/781878
    Signed-off-by: Sam James <sam@gentoo.org>

 eclass/python-utils-r1.eclass | 3 +++
 1 file changed, 3 insertions(+)
Comment 5 Ionen Wolkens gentoo-dev 2021-04-10 04:44:23 UTC
*** Bug 781893 has been marked as a duplicate of this bug. ***