Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 778446 - =media-tv/kodi-19.0 stablereq
Summary: =media-tv/kodi-19.0 stablereq
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Craig Andrews
URL:
Whiteboard:
Keywords: CC-ARCHES, STABLEREQ
Depends on: 779184
Blocks:
  Show dependency tree
 
Reported: 2021-03-26 14:28 UTC by Gabriel
Modified: 2021-07-26 01:39 UTC (History)
5 users (show)

See Also:
Package list:
media-tv/kodi-19.0 amd64 x86 arm64 dev-libs/libudfread-1.1.1 amd64 x86 arm64 dev-libs/flatbuffers-1.12.0 amd64 x86 arm64 app-pda/libplist-2.2.0-r3 amd64 x86 arm64 dev-cpp/waylandpp-0.2.8 amd64 x86 arm64 dev-libs/crossguid-0_pre20150817 amd64 x86 arm64 dev-libs/libfstrcmp-0.7-r1 amd64 x86 arm64 media-fonts/roboto-2.138 amd64 x86 arm64 media-libs/libao-1.2.2-r1 amd64 x86 arm64 dev-libs/libcec-6.0.2 amd64 x86 arm64 net-libs/shairplay-0_pre20180824-r1 amd64 x86 arm64 dev-libs/libplatform-2.1.0.1-r1 amd64 x86 arm64
Runtime testing required: ---
nattka: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel 2021-03-26 14:28:43 UTC
Kodi has been working fine (even in its alpha versions) on my amd64 for a very long time, so I'm softly requesting stabilisation.
I am aware of https://bugs.gentoo.org/736667 and https://bugs.gentoo.org/730216 - to be honest, I don't know what use case requires Kodi to use mariadb or mysql, so I would consider masking those flags so that folks can have a stable version of Kodi readily available.
Comment 1 NATTkA bot gentoo-dev 2021-03-27 23:52:58 UTC Comment hidden (obsolete)
Comment 2 Gabriel 2021-03-28 09:24:58 UTC
FWIW, I haven't got dev-libs/libudfread in the system where I'm running Kodi - I admit that my USE flags are very conservative: /etc/portage/package.use/use:media-tv/kodi nfs airplay upnp webserver zeroconf -wayland
Comment 3 NATTkA bot gentoo-dev 2021-03-28 20:36:52 UTC Comment hidden (obsolete)
Comment 4 NATTkA bot gentoo-dev 2021-03-28 20:57:38 UTC Comment hidden (obsolete)
Comment 5 NATTkA bot gentoo-dev 2021-03-28 21:05:05 UTC Comment hidden (obsolete)
Comment 6 NATTkA bot gentoo-dev 2021-03-28 21:09:38 UTC Comment hidden (obsolete)
Comment 7 Sam James archtester gentoo-dev Security 2021-03-29 14:50:01 UTC
arm64 done
Comment 8 NATTkA bot gentoo-dev 2021-04-01 18:54:38 UTC Comment hidden (obsolete)
Comment 9 NATTkA bot gentoo-dev 2021-04-01 20:08:33 UTC Comment hidden (obsolete)
Comment 10 NATTkA bot gentoo-dev 2021-04-01 21:51:10 UTC Comment hidden (obsolete)
Comment 11 NATTkA bot gentoo-dev 2021-04-16 13:54:24 UTC Comment hidden (obsolete)
Comment 12 NATTkA bot gentoo-dev 2021-04-16 13:56:58 UTC
All sanity-check issues have been resolved
Comment 13 Sam James archtester gentoo-dev Security 2021-05-16 18:53:28 UTC
x86 done
Comment 14 Frank Krömmelbein 2021-07-04 20:44:50 UTC
It would be nice if it continued with the remaining architectures.
Furthermore, because of the delay, it would now make sense to stabilize version 19.1 of kodi right away.
Comment 15 Sam James archtester gentoo-dev Security 2021-07-26 01:39:33 UTC
amd64 done

all arches done