Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 777636 - dev-libs/glib-2.74.6 [gtk-doc] fails to build: ERROR: Unknown variable "libgdbus_example_objectmanager_dep".
Summary: dev-libs/glib-2.74.6 [gtk-doc] fails to build: ERROR: Unknown variable "libgd...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
: 878473 (view as bug list)
Depends on:
Reported: 2021-03-22 06:00 UTC by Leonid Kopylov
Modified: 2023-05-10 17:42 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,36.17 KB, text/plain)
2021-03-22 06:00 UTC, Leonid Kopylov

Note You need to log in before you can comment on or make changes to this bug.
Description Leonid Kopylov 2021-03-22 06:00:17 UTC
# emerge -pqv '=dev-libs/glib-2.68.0::gentoo'
[ebuild   R   ] dev-libs/glib-2.68.0  USE="dbus elf fam gtk-doc* (mime) utils xattr -debug (-selinux) -static-libs -sysprof -systemtap -test" ABI_X86="32 (64) (-x32)"

#  emerge --info '=dev-libs/glib-2.68.0::gentoo'
Portage 3.0.17 (python 3.8.8-final-0, default/linux/amd64/17.1/desktop/systemd, gcc-10.2.0, glibc-2.32-r8, 5.11.8-gentoo x86_64)
                         System Settings
System uname: Linux-5.11.8-gentoo-x86_64-Intel-R-_Core-TM-_i7-10710U_CPU_@_1.10GHz-with-glibc2.2.5
KiB Mem:     8149664 total,   2252692 free
KiB Swap:    8388604 total,   8384728 free
Timestamp of repository gentoo: Sun, 21 Mar 2021 12:00:01 +0000
Head commit of repository gentoo: 55b02192e6405d0c9121f91fc6a9466746501df4
sh bash 5.1_p4
ld GNU ld (Gentoo 2.35.2 p1) 2.35.2
ccache version 4.2 [disabled]
app-shells/bash:          5.1_p4::gentoo
dev-lang/perl:            5.32.1::gentoo
dev-lang/python:          3.8.8::gentoo, 3.9.2::gentoo, 3.10.0_alpha6-r2::gentoo
dev-util/ccache:          4.2::gentoo
dev-util/cmake:           3.19.7::gentoo
sys-apps/baselayout:      2.7-r1::gentoo
sys-apps/sandbox:         2.21::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.71::gentoo
sys-devel/automake:       1.16.3-r1::gentoo
sys-devel/binutils:       2.35.2::gentoo
sys-devel/gcc:            10.2.0-r5::gentoo
sys-devel/gcc-config:     2.4::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.11::gentoo (virtual/os-headers)
sys-libs/glibc:           2.32-r8::gentoo

    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA google-chrome OPERA-2018 PUEL AnyDesk-TOS geekbench TeamViewer microsoft-edge"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
FCFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X a52 aac accessibility acl acpi alsa amd64 audit berkdb bluetooth branding bzip2 cairo ccache cdda cdr cgroup-hybrid cli crypt cryptsetup cups dbus device-mapper doc dot doxysearch dri dts dvd dvdr emboss encode examples exif experimental fam firmware flac fontconfig fortran games gd gdbm gif git go google gpg gpm gtk gtk-doc gui highlight html http iconv icu idn ipv6 iscsi jadetex jpeg json kerberos lcms ldap ldap-bind ldap-sasl leaps-timezone libglvnd libkms libnotify libtirpc logrotate lz4 mad mdadm minizip mng mongo mongodb mount mp3 mp4 mpeg mpx multilib mysql ncurses netgroups nis nls nptl nscd offensive ogg opengl openldap openmp openntpd pam pango parse-clocks pcre pdf perl png policykit postgres ppds python qrcode qt5 readline sasl savedconfig sdl sdl-image seccomp security-key slp source source-highlight spell split-usr spoof-source sql sqlite ssl startup-notification svg symlink sync-plugin-portage systemd tcl tcpd threads tiff tk tools truetype tty-helpers udev udisks unicode upower usb utils vim vim-pager vim-syntax vorbis wayland wifi winbind wininst wxwidgets x264 xa xattr xcb xetex xinerama xkb xml xv xvid yaml zlib zstd" ABI_X86="64 32" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt rdrand sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev" KERNEL="linux" L10N="en en-US he ru" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver scripting-beanshell wiki-publisher scripting-javascript" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_8" PYTHON_TARGETS="python3_8" RUBY_TARGETS="ruby25 ruby26 ruby27 ruby30" USERLAND="GNU" VIDEO_CARDS="intel i965 iris vmware vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

dev-libs/glib-2.68.0::gentoo was built with the following:
USE="dbus elf fam (mime) utils xattr -debug -gtk-doc (-selinux) -static-libs -sysprof -systemtap -test" ABI_X86="32 (64) (-x32)"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer -DG_DISABLE_CAST_CHECKS -DG_DISABLE_CAST_CHECKS"
FEATURES="assume-digests sfperms usersync unmerge-logs merge-sync unmerge-orphans userpriv usersandbox unknown-features-warn binpkg-docompress fixlafiles preserve-libs binpkg-logs sandbox config-protect-if-modified xattr strict protect-owned pid-sandbox binpkg-dostrip parallel-fetch network-sandbox ebuild-locks qa-unresolved-soname-deps multilib-strict ipc-sandbox news distlocks userfetch"
Comment 1 Leonid Kopylov 2021-03-22 06:00:54 UTC
Created attachment 692856 [details]
Comment 3 Matt Turner gentoo-dev 2021-04-18 15:31:29 UTC
(In reply to Chris Mayo from comment #2)
> Needs USE="test".
> e1744603d8c8b4ac9763854ce658c241b3c5fc3a

Thanks, but I don't follow. What is your suggestion?
Comment 4 Chris Mayo 2021-04-18 17:47:47 UTC
Unfortunately I don't think there is much that can be done, only:

REQUIRED_USE="gtk-doc? ( test )"
Comment 5 Red 2021-05-30 12:20:22 UTC
True of =dev-libs/glib-2.68.2 as well
Comment 6 Maxim P. Dementiev 2021-06-02 21:50:17 UTC
I've got the same problem since 3 days or so.
Comment 7 Larry the Git Cow gentoo-dev 2021-06-04 03:12:17 UTC
The bug has been closed via the following commit(s):

commit bf1d1df9303a42af1682f7a2a0a00e6a9905cde9
Author:     Matt Turner <>
AuthorDate: 2021-06-04 02:58:06 +0000
Commit:     Matt Turner <>
CommitDate: 2021-06-04 03:11:53 +0000

    dev-libs/glib: Require USE=test for USE=gtk-doc
    Signed-off-by: Matt Turner <>

 dev-libs/glib/glib-2.68.2.ebuild | 1 +
 1 file changed, 1 insertion(+)
Comment 8 Mart Raudsepp gentoo-dev 2021-07-06 16:27:12 UTC
Can't we silently enable tests meson option in case of USE=gtk-doc, but not run the tests?
Comment 9 Matt Turner gentoo-dev 2021-07-06 18:07:57 UTC
(In reply to Mart Raudsepp from comment #8)
> Can't we silently enable tests meson option in case of USE=gtk-doc, but not
> run the tests?

I didn't consider that. If that works, I'll all for it!
Comment 10 Mart Raudsepp gentoo-dev 2022-05-16 10:01:42 UTC
Reopening to look into actually doing that eventually then (or potentially better solutions by now)
Comment 11 Agostino Sarubbo gentoo-dev 2022-11-26 19:51:41 UTC
ci has reproduced this issue with version 2.74.2 - Updating summary.
Comment 12 Agostino Sarubbo gentoo-dev 2022-12-01 15:58:29 UTC
ci has reproduced this issue with version 2.74.3 - Updating summary.
Comment 13 Agostino Sarubbo gentoo-dev 2022-12-02 06:49:55 UTC
ci has reproduced this issue with version 2.74.3-r1 - Updating summary.
Comment 14 Matt Turner gentoo-dev 2022-12-04 19:47:50 UTC
*** Bug 878473 has been marked as a duplicate of this bug. ***
Comment 15 Agostino Sarubbo gentoo-dev 2022-12-14 08:34:29 UTC
ci has reproduced this issue with version 2.74.3-r2 - Updating summary.
Comment 16 Agostino Sarubbo gentoo-dev 2022-12-16 13:39:01 UTC
ci has reproduced this issue with version 2.74.3-r3 - Updating summary.
Comment 17 Agostino Sarubbo gentoo-dev 2022-12-22 07:53:55 UTC
ci has reproduced this issue with version 2.74.4 - Updating summary.
Comment 18 Agostino Sarubbo gentoo-dev 2023-01-21 20:46:26 UTC
ci has reproduced this issue with version 2.74.5 - Updating summary.
Comment 19 Agostino Sarubbo gentoo-dev 2023-02-26 07:09:08 UTC
ci has reproduced this issue with version 2.74.6 - Updating summary.
Comment 20 Matt Turner gentoo-dev 2023-03-11 14:36:36 UTC
(In reply to Matt Turner from comment #9)
> (In reply to Mart Raudsepp from comment #8)
> > Can't we silently enable tests meson option in case of USE=gtk-doc, but not
> > run the tests?
> I didn't consider that. If that works, I'll all for it!

I tried this and it's not trivial because of

>		# Don't build tests, also prevents extra deps, bug #512022
>		sed -i -e '/subdir.*tests/d' {.,gio,glib}/ || die

in src_prepare().
Comment 21 ginny690901 2023-03-25 17:10:37 UTC
I don't know why the line
is removed at all....
As long as USE=-test is active the tests won't be build anyway...

And for the problem with USE="-test gtk-doc" I changed 'docs/reference/' by wrapping a few offensing lines (the second line and the block 'content_files += [ ... ]') with:

if build_tests

Worked like a charm :)
Comment 22 Leonid Kopylov 2023-05-10 17:42:25 UTC
seems issue solved:

# emerge dev-libs/glib -pvq
[ebuild   R   ] dev-libs/glib-2.76.2  USE="dbus elf gtk-doc (mime) sysprof test utils xattr -debug (-selinux) -static-libs -systemtap" ABI_X86="32 (64) (-x32)"