Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 777324 - sys-kernel/linux-firmware-20210315 breaks AX210 Wifi when using <linux-5.12
Summary: sys-kernel/linux-firmware-20210315 breaks AX210 Wifi when using <linux-5.12
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Chí-Thanh Christopher Nguyễn
URL: https://bugs.archlinux.org/task/70071
Whiteboard:
Keywords:
: 777342 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-03-19 21:24 UTC by Rodrigo Saboya
Modified: 2021-03-27 00:54 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rodrigo Saboya 2021-03-19 21:24:33 UTC
I recently updated the packages on my laptop and realized the Wifi card wasn't working. Turns out sys-kernel/linux-firmware-20210315 makes the Wifi card non-functional. Here is the dmesg log (taken from the linked bug report from Arch Linux. Mine was basically the same, but I already fixed it):

iwlwifi 0000:05:00.0: api flags index 2 larger than supported by driver
iwlwifi 0000:05:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 93.8.63.28
iwlwifi 0000:05:00.0: loaded firmware version 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
iwlwifi 0000:05:00.0: Detected Intel(R) Wi-Fi 6 AX210 160MHz, REV=0x420
iwlwifi 0000:05:00.0: loaded PNVM version 0x324cd670
iwlwifi 0000:05:00.0: Timeout waiting for PNVM load!

Reverting to sys-kernel/linux-firmware-20210208 fixes the issue and the card works again (log from my actual machine):

[    2.615175] iwlwifi 0000:07:00.0: api flags index 2 larger than supported by driver
[    2.615200] iwlwifi 0000:07:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 93.8.63.28
[    2.615550] iwlwifi 0000:07:00.0: loaded firmware version 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
[    2.641364] iwlwifi 0000:07:00.0: Detected Intel(R) Wi-Fi 6 AX210 160MHz, REV=0x420



Reproducible: Always

Steps to Reproduce:
1. Have AX210 Wifi card
2. Install sys-kernel/linux-firmware-20210315
3.
Actual Results:  
AX210 Wifi card stops working.

Expected Results:  
A working Wifi card.
Comment 1 Thomas Deutschmann gentoo-dev Security 2021-03-20 00:46:38 UTC
Please add information about used kernel version.
Comment 2 Rodrigo Saboya 2021-03-20 01:06:48 UTC
Kernel version used: 5.11.7-r1
Comment 3 Thomas Deutschmann gentoo-dev Security 2021-03-20 01:35:30 UTC
The shown dmesg output is identical and is showing same firmware file/version.
Comment 4 Ionen Wolkens gentoo-dev 2021-03-20 05:45:48 UTC
*** Bug 777342 has been marked as a duplicate of this bug. ***
Comment 5 Rodrigo Saboya 2021-03-20 10:47:29 UTC
Well I don't disagree with you, I'm just reporting exactly what is happenning. I just emerged linux-firmware-20210315 again to confirm, and here it is:

[    3.731269] iwlwifi 0000:07:00.0: api flags index 2 larger than supported by driver
[    3.731295] iwlwifi 0000:07:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 93.8.63.28
[    3.731603] iwlwifi 0000:07:00.0: loaded firmware version 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
[    3.748599] iwlwifi 0000:07:00.0: Detected Intel(R) Wi-Fi 6 AX210 160MHz, REV=0x420
[    3.909133] iwlwifi 0000:07:00.0: loaded PNVM version 0x324cd670
[    4.010747] iwlwifi 0000:07:00.0: Timeout waiting for PNVM load!
[    4.010754] iwlwifi 0000:07:00.0: Failed to start RT ucode: -110
[    4.010759] iwlwifi 0000:07:00.0: iwl_trans_send_cmd bad state = 1
[    4.214074] iwlwifi 0000:07:00.0: firmware didn't ACK the reset - continue anyway
[    4.226635] iwlwifi 0000:07:00.0: Failed to run INIT ucode: -110

Not sure if the PNVM file is faulty for this particular wifi adapter or not, if it's only compatible with the latest version (which, for some reason, is not being selected, which should be the 62.ucode merged recently).

Relevant commit in linux-firmware between the working / non-working versions:
https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/commit/?id=5a2fd63596125d4ed5ac65614b1811b2d4a68536
Comment 6 Rodrigo Saboya 2021-03-20 11:10:10 UTC
So yeah, that's the issue. The same update that updated the fw version to 62 also introduced a PNVM file. That PNVM file is searched for and loaded in case it's found. However, apparently it only works with the new 62 version firmware. And I can confirm this because I manually bumped the max version in the kernel (like this commit, in 5.12):

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/drivers/net/wireless/intel/iwlwifi/cfg/22000.c?id=000735e5dbbb739ca3742413858c1d9cac899e10

And now it works with the latest linux-firmware-20210315:

[    3.162237] iwlwifi 0000:07:00.0: api flags index 2 larger than supported by driver
[    3.162271] iwlwifi 0000:07:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 0.59.2.22
[    3.162579] iwlwifi 0000:07:00.0: loaded firmware version 62.49eeb572.0 ty-a0-gf-a0-62.ucode op_mode iwlmvm
[    3.181070] iwlwifi 0000:07:00.0: Detected Intel(R) Wi-Fi 6 AX210 160MHz, REV=0x420
[    3.338164] iwlwifi 0000:07:00.0: loaded PNVM version 0x324cd670
[    3.417160] iwlwifi 0000:07:00.0: base HW address: d8:f8:83:35:ea:bc
[    3.448157] iwlwifi 0000:07:00.0 wlp7s0: renamed from wlan0
Comment 7 Thomas Deutschmann gentoo-dev Security 2021-03-20 15:16:12 UTC
Thank you for your report and your analysis!

But please read bug 704084 comment #3. There is really nothing we can do for you. Masking the new version would be problematic for those running latest versions.
Comment 8 Rodrigo Saboya 2021-03-20 18:31:19 UTC
I understand. The bug report is probably useful for people bumping into the same issue. I can deal with it locally just fine.

Can't the patch that I linked (bumping IWL_22000_UCODE_API_MAX) be backported from 5.12 at least?
Comment 9 Thomas Deutschmann gentoo-dev Security 2021-03-20 19:24:51 UTC
Please ping Intel maintainer/linux-stable mailing list and ask for this. It's possible that the new firmware will also require additional driver changes which are not present in previous kernel version.
Comment 10 Austin Kilgore 2021-03-22 03:12:08 UTC
Same problem here on my AX210.
Comment 11 Austin Kilgore 2021-03-27 00:54:27 UTC
An easy fix for this right now can be to just build-in the firmware for the ax210 into your kernel.