Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 777099 - dev-libs/apr-util-1.6.1-r6 rlibtool: error logged in slbt_lconf_open(), line 73: flow error: unexpected condition or other. when using rlibtool
Summary: dev-libs/apr-util-1.6.1-r6 rlibtool: error logged in slbt_lconf_open(), line ...
Status: RESOLVED DUPLICATE of bug 779487
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: slibtool rlibtool
  Show dependency tree
 
Reported: 2021-03-18 19:35 UTC by Alessandro Barbieri
Modified: 2021-03-31 14:38 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
apr-util-1.6.1-r6:20210318-035228.log (apr-util-1.6.1-r6:20210318-035228.log,19.75 KB, text/plain)
2021-03-18 19:35 UTC, Alessandro Barbieri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro Barbieri 2021-03-18 19:35:42 UTC
rlibtool: error logged in slbt_lconf_open(), line 73: flow error: unexpected condition or other.
rlibtool: < returned to > slbt_get_lconf_flags(), line 113.
make[1]: *** [/var/tmp/portage/dev-libs/apr-util-1.6.1-r6/work/apr-util-1.6.1/build/rules.mk:203: buckets/apr_buckets_pipe.lo] Error 2
make[1]: *** Waiting for unfinished jobs....
rlibtool: error logged in slbt_lconf_open(), line 73: flow error: unexpected condition or other.
rlibtool: < returned to > slbt_get_lconf_flags(), line 113.
make[1]: *** [/var/tmp/portage/dev-libs/apr-util-1.6.1-r6/work/apr-util-1.6.1/build/rules.mk:203: buckets/apr_buckets_pool.lo] Error 2
make[1]: Leaving directory '/var/tmp/portage/dev-libs/apr-util-1.6.1-r6/work/apr-util-1.6.1'
make: *** [/var/tmp/portage/dev-libs/apr-util-1.6.1-r6/work/apr-util-1.6.1/build/rules.mk:115: all-recursive] Error 1
 * ERROR: dev-libs/apr-util-1.6.1-r6::gentoo failed (compile phase):
 *   emake failed
Comment 1 Alessandro Barbieri 2021-03-18 19:35:59 UTC
Created attachment 692307 [details]
apr-util-1.6.1-r6:20210318-035228.log

buildlog
Comment 2 orbea 2021-03-18 19:56:27 UTC
Should work with slibtool-shared.
Comment 3 orbea 2021-03-31 14:38:25 UTC

*** This bug has been marked as a duplicate of bug 779487 ***