Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 77206 - vmware 5.0 beta build 11888 (version bump)
Summary: vmware 5.0 beta build 11888 (version bump)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo VMWare Bug Squashers [disabled]
Depends on:
Reported: 2005-01-09 02:16 UTC by Mark Janssen
Modified: 2005-01-18 13:59 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

vmware 5.0 beta build 11888 ebuild (vmware-workstation-5.0_beta2.ebuild,5.81 KB, application/octet-stream)
2005-01-11 08:55 UTC, Mark Janssen

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janssen 2005-01-09 02:16:42 UTC
Request for a version bump to build 11888 of the beta. This fixes many issues including a problem with NTPL threading.

Reproducible: Always
Steps to Reproduce:
Comment 1 Mark Janssen 2005-01-09 02:18:19 UTC
... and of course I meant NPTL.
Comment 2 Geoff Mishkin 2005-01-11 08:46:41 UTC
Could probably get away with just changing the name of the distfile and associated checksum.  I doubt the installation procedure changed any between it and the last 5.0 beta.

Which begs the question, what do we call it?  IMO they should be called 5.0.11608 and 5.0.11888 like the 4.x versions are.
Comment 3 Mark Janssen 2005-01-11 08:55:45 UTC
Created attachment 48214 [details]
vmware 5.0 beta build 11888 ebuild

A new ebuild for build 11888. I've only changed the NP variable, and it works
I called it beta2, but it'd have been better to use the build numbers.
Comment 4 Dylan Carlson (RETIRED) gentoo-dev 2005-01-15 21:02:34 UTC
Committed, thanks.
Comment 5 Stefan Schweizer (RETIRED) gentoo-dev 2005-01-16 00:05:55 UTC
Can we please remove the fetch restrictions for this public beta?

I seem to be able to get the file from:
Comment 6 Mark Janssen 2005-01-16 02:15:57 UTC
There is a license agreement before downloading, though.
Comment 7 Chris Gianelloni (RETIRED) gentoo-dev 2005-01-16 07:23:53 UTC
Since you've read the licensing agreement, I'm sure.  Is there anything in it that would seem to prohibit us from being able to fetch the files for the user?  I think the fetch restriction should be removed and the restriction should be changed to nomirror.
Comment 8 aaron bowman 2005-01-18 11:49:29 UTC
So are users unable to install this beta?  I attempted to run "ACCEPT_KEYWORDS="~x86" emerge =vmware-workstation-5.0_beta2 
and got an error saying that I need to unmask it, which I haven't been able to figure out how to do.
Comment 9 Mark Janssen 2005-01-18 11:55:47 UTC
Unmask it by adding it to package.unmask.
Beta packages are not the same as testing (~arch) packages.
Comment 10 aaron bowman 2005-01-18 13:14:41 UTC
I've never done unmasking, but I found that you are supposed to take the masked entry in /usr/portage/profiles/package.mask and put that into the package.unmask file.  I had to create the package.unmask file (put it in /etc/portage/) and I put in the entry from the mask file which was >=app-emulation/vmware-workstation-5.0_beta1
into the package.unmask file.
I was still unable to install from any of the following commands:

emerge vmware-workstation-5.0_beta1
emerge =vmware-workstation-5.0_beta1
ACCEPT_KEYWORD="~x86" =vmware-workstation-5.0_beta1

I also tried those same commands with beta2 instead of beta1

Any help would be appreciated.  If this but is not the appropriate place to ask, I apologize.  Could I email you or should I actually create a new bug report on this?
Comment 11 Mark Janssen 2005-01-18 13:36:34 UTC
"emerge vmware-workstation" should work fine.
What error do you get when you run the above command?
Comment 12 aaron bowman 2005-01-18 13:49:56 UTC
If I run: emerge vmware-workstation it starts installing workstation 4.5.2

I'm wanting 5.0 beta 2 but I must be doing something wrong in the unmasking.  See my above post for what I did.
Comment 13 Mark Janssen 2005-01-18 13:56:17 UTC
I got
in /etc/portage/package.unmask
Comment 14 Chris Gianelloni (RETIRED) gentoo-dev 2005-01-18 13:59:26 UTC
This is a bug report, not a web forum.  This bug was for the new version of the ebuild.  Your problem getting the beta version installed is a configuration issue and not a bug.  I would suggest moving this to the gentoo-user mailing list or to the forums.