Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 771036 - media-plugins/vdr-xineliboutput-2.2.0-r2 calls cc directly
Summary: media-plugins/vdr-xineliboutput-2.2.0-r2 calls cc directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo VDR Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2021-02-17 07:31 UTC by Agostino Sarubbo
Modified: 2021-04-05 09:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,15.25 KB, text/plain)
2021-02-17 07:31 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2021-02-17 07:31:27 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: media-plugins/vdr-xineliboutput-2.2.0-r2 calls cc directly.
Discovered on: amd64 (internal ref: ci)

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different CC implementation (like clang). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the CC variable to x86_64-pc-linux-gnu-gcc.
Comment 1 Agostino Sarubbo gentoo-dev 2021-02-17 07:31:29 UTC
Created attachment 687075 [details]
build.log

build log and emerge --info
Comment 2 Joerg Bornkessel gentoo-dev 2021-03-24 19:36:52 UTC
it's easy to fix,
but then it breaks with llvm/clang,

both are fixed here localy, will add fix(es) then soon,...
Comment 3 Larry the Git Cow gentoo-dev 2021-04-05 09:06:56 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=eb20013b2a9e72a1dbc298ed65051201e14502f1

commit eb20013b2a9e72a1dbc298ed65051201e14502f1
Author:     Joerg Bornkessel <hd_brummy@gentoo.org>
AuthorDate: 2021-04-05 09:05:54 +0000
Commit:     Joerg Bornkessel <hd_brummy@gentoo.org>
CommitDate: 2021-04-05 09:06:47 +0000

    media-plugins/vdr-xineliboutput: calls cc directly fixed
    
    this commit will also fix the compile with llvm/clang,
    the llvm/clang patch will fix only the errors to prevent
    the plugin from compile,
    a lot of warnings on llvm/clang are still exist
    
    Closes: https://bugs.gentoo.org/771036
    Package-Manager: Portage-3.0.14, Repoman-3.0.2
    Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>

 media-plugins/vdr-xineliboutput/Manifest           |   2 +-
 .../vdr-xineliboutput-2.1.0-r1.ebuild              | 149 ---------------------
 .../vdr-xineliboutput-2.2.0-r1.ebuild              | 148 --------------------
 ...r2.ebuild => vdr-xineliboutput-2.2.0-r3.ebuild} |  11 +-
 4 files changed, 8 insertions(+), 302 deletions(-)