Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 768051 - dev-db/mysql-init-scripts tmpfiles.d references /var/run/ still
Summary: dev-db/mysql-init-scripts tmpfiles.d references /var/run/ still
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Linux MySQL bugs team
URL:
Whiteboard:
Keywords: PullRequest
: 804858 807592 832901 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-01-31 12:39 UTC by Philippe Chaintreuil
Modified: 2022-04-15 08:10 UTC (History)
18 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
rc.log (rc.log,8.00 KB, text/x-log)
2021-05-10 08:15 UTC, Grigor Lekarov
Details
emerge --info (emerge_info.txt,6.46 KB, text/plain)
2021-05-10 08:16 UTC, Grigor Lekarov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Chaintreuil 2021-01-31 12:39:09 UTC
I've noticed the following warning during boot:
======================================================================
* Setting up tmpfiles.d entries ...
/usr/lib/tmpfiles.d/mysql.conf:1: Line references path below legacy directory /var/run/, updating /var/run/mysqld  /run/mysqld; please update the tmpfiles.d/ drop-in file accordingly.
======================================================================

${FILESDIR}/mysql.conf should be modernized.

Reproducible: Always
Comment 1 Ionen Wolkens gentoo-dev 2021-01-31 16:02:08 UTC
In case unclear, this happens with systemd-tmpfiles (opentmpfiles won't emit warnings on this).
Comment 2 Philippe Chaintreuil 2021-05-05 12:54:58 UTC
Friendly ping (it's been 3 months).
Comment 3 Grigor Lekarov 2021-05-10 08:14:48 UTC
Same issue on a brand new installation only.

This message doesn't appear after update an environment installed few years ago.
Comment 4 Grigor Lekarov 2021-05-10 08:15:46 UTC
Created attachment 706779 [details]
rc.log
Comment 5 Grigor Lekarov 2021-05-10 08:16:28 UTC
Created attachment 706782 [details]
emerge --info
Comment 6 Grigor Lekarov 2021-05-10 08:28:35 UTC
A workaround of this case is to edit /usr/lib/tmpfiles.d/mysql.conf and replace d /var/run/mysqld 0755 mysql mysql -

with

d /run/mysqld 0755 mysql mysql -

as /var/run is a symlink to /run

Although it'll be better to update dev-db/mysql-init-scripts/files/mysql.conf if it doesn't lead to another issues.
Comment 7 Thomas Deutschmann gentoo-dev 2021-05-10 11:41:51 UTC
This is not critical, it is just a pointless warning from your init system without any impact. It's scheduled for next bump but there are other, real issues, which require testing, before we can tag a new release.


PS: Do not edit /usr/lib/tmpfiles.d/mysql.conf. Copy that file to /etc/tmpfiles.d and edit it there if you need to.
Comment 8 Tomáš Mózes 2021-07-08 07:46:50 UTC
Opentmpfiles got masked so after an update (and migration to systemd-tmpfiles) I got this in the logs too.
Comment 9 Mike Gilbert gentoo-dev 2021-07-28 14:46:59 UTC
*** Bug 804858 has been marked as a duplicate of this bug. ***
Comment 10 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-08-11 02:22:42 UTC
*** Bug 807592 has been marked as a duplicate of this bug. ***
Comment 11 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-12-20 07:37:35 UTC
*** Bug 829695 has been marked as a duplicate of this bug. ***
Comment 12 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-12-20 07:37:55 UTC
(In reply to Thomas Deutschmann from comment #7)
> This is not critical, it is just a pointless warning from your init system
> without any impact. It's scheduled for next bump but there are other, real
> issues, which require testing, before we can tag a new release.
> 
> 
> PS: Do not edit /usr/lib/tmpfiles.d/mysql.conf. Copy that file to
> /etc/tmpfiles.d and edit it there if you need to.

We've been waiting quite a long time. Can you please merge the PR?
Comment 13 Massimo Burcheri 2021-12-23 16:48:32 UTC
Found this bug as I have similar messages:

 * Setting up tmpfiles.d entries ...
/usr/lib/tmpfiles.d/xl2tpd.conf:1: Line references path below legacy directory /var/run/, updating /var/run/xl2tpd  /run/xl2tpd; please update the tmpfiles.d/ drop-in file accordingly.

* Setting up tmpfiles.d entries for /dev ...
/usr/lib/tmpfiles.d/xl2tpd.conf:1: Line references path below legacy directory /var/run/, updating /var/run/xl2tpd  /run/xl2tpd; please update the tmpfiles.d/ drop-in file accordingly.

Is that the same issue or should be filed separately?
Comment 14 Philippe Chaintreuil 2021-12-23 17:17:08 UTC
That sounds like a separate issue with xl2tpd -- you should open a separate bug if there isn't already one.
Comment 15 Massimo Burcheri 2022-01-11 10:08:59 UTC
-> bug 829885
Comment 16 diamond 2022-02-04 12:46:49 UTC
It looks like the following files have to be changed:
/etc/mysql/mysql.d/50-distro-client.cnf
/etc/mysql/mysql.d/50-distro-server.cnf
/var/run/ -> /run/
Comment 17 Philippe Chaintreuil 2022-02-07 15:45:37 UTC
(In reply to diamond from comment #16)
> It looks like the following files have to be changed:
> /etc/mysql/mysql.d/50-distro-client.cnf
> /etc/mysql/mysql.d/50-distro-server.cnf
> /var/run/ -> /run/

Those files are installed by a different ebuild (dev-db/mysql proper).  You should create a new, separate bug for those.
Comment 18 diamond 2022-02-08 11:32:33 UTC
I added bug #832901.
Comment 19 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-02-10 05:08:18 UTC
*** Bug 832901 has been marked as a duplicate of this bug. ***
Comment 20 Philippe Chaintreuil 2022-02-15 20:54:52 UTC
Apologies for leading you astray, "Diamond".  (I guess Sam thinks they both belong in here.)
Comment 21 Philippe Chaintreuil 2022-04-14 18:40:04 UTC
I think this has been closed by https://github.com/gentoo/gentoo/commit/a2e045276140813d197d5eb341bb583dc76cac41
Comment 22 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-04-15 08:10:08 UTC
(In reply to Philippe Chaintreuil from comment #21)
> I think this has been closed by
> https://github.com/gentoo/gentoo/commit/
> a2e045276140813d197d5eb341bb583dc76cac41

Thanks.