Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 766914 - dev-python/wxpython-4.1.1 version bump
Summary: dev-python/wxpython-4.1.1 version bump
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo wxWidgets Herd
URL:
Whiteboard:
Keywords:
Depends on: 577030
Blocks:
  Show dependency tree
 
Reported: 2021-01-24 18:40 UTC by m.manico
Modified: 2021-01-26 02:32 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.manico 2021-01-24 18:40:19 UTC
wxPython 4.1.1 is released
https://www.wxpython.org/news/2020-11-21-wxpython-411-release/index.html

Reproducible: Always
Comment 1 Mart Raudsepp gentoo-dev 2021-01-25 08:51:03 UTC
wxPython 4.1 tracks wxWidgets (wxGTK) 3.1.x, which is a development release without ABI stability. Does wxPython 4.1.1 build and work properly against wxGTK-3.0.x, do you know?
Comment 2 m.manico 2021-01-25 09:33:19 UTC
I don't know. I did not investigate requirements/context when filing this bump request.

I guess we wait for wxGTK 3.1.x to stabilize for it to enter the portage tree, which is tracked at https://bugs.gentoo.org/577030
Comment 3 Ștefan Talpalaru 2021-01-26 02:32:02 UTC
(In reply to Mart Raudsepp from comment #1)
> Does wxPython 4.1.1 build and work properly against
> wxGTK-3.0.x, do you know?

wxPython-4.1.1 depends on an unreleased wxWidgets-3.1.5, so it cannot be built with the system wxWidgets (wxGTK): https://github.com/wxWidgets/Phoenix/issues/1909

The best you can do right now is wxPython-4.1.0 and wxGTK-3.1.4.