Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 76676 - "equery files" says internal error when including the version of hotplug
Summary: "equery files" says internal error when including the version of hotplug
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Tools (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Portage Tools Team
URL:
Whiteboard:
Keywords: InVCS
: 115793 124101 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-01-04 12:32 UTC by Adam
Modified: 2006-02-25 13:45 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam 2005-01-04 12:32:14 UTC
Here are the results of 2 equery commands:

root>equery files sys-apps/hotplug-20040923
[ Searching for packages matching sys-apps/hotplug-20040923... ]
!!! Internal portage error, terminating
Traceback (most recent call last):
  File "/usr/bin/equery", line 1565, in ?
    print_error(e)
  File "/usr/lib/gentoolkit/pym/gentoolkit/pprinter.py", line 14, in print_error
    sys.stderr.write(output.red("!!! ") + s + "\n")
TypeError: cannot concatenate 'str' and 'instance' objects

root>equery files hotplug-20040923
[ Searching for packages matching hotplug-20040923... ]
!!! Internal portage error, terminating
Traceback (most recent call last):
  File "/usr/bin/equery", line 1565, in ?
    print_error(e)
  File "/usr/lib/gentoolkit/pym/gentoolkit/pprinter.py", line 14, in print_error
    sys.stderr.write(output.red("!!! ") + s + "\n")
TypeError: cannot concatenate 'str' and 'instance' objects

When I simply run "equery files hotplug", it works fine.


Reproducible: Always
Steps to Reproduce:
1. Run the command "equery files hotplug-20040923"

Actual Results:  
Said there's an internal error

Expected Results:  
Shown the files in hotplug

adam>emerge info
Portage 2.0.51-r3 (default-linux/x86/2004.3, gcc-3.3.4, glibc-2.3.3.20040420-r2,
2.6.9-gentoo-r9 i686)
=================================================================
System uname: 2.6.9-gentoo-r9 i686 AMD Athlon(tm) XP 2500+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.90.0.1.1-r3
Headers:  sys-kernel/linux-headers-2.4.21-r1
Libtools: sys-devel/libtool-1.5.2-r7
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config
/usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks nostrip sandbox sfperms strict
userpriv usersandbox"
GENTOO_MIRRORS="http://adelie.polymtl.ca/ http://mirror.datapipe.net/gentoo
http://mirror.clarkson.edu/pub/distributions/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow acl alsa arts avi bitmap-fonts cdr crypt cups dvd encode fam
foomaticdb fortran gdbm gif gpm gtk2 imagemagick imlib ipv6 java jpeg junit kde
libwww mmx mozilla mpeg mysql ncurses oggvorbis opengl pam pdflib perl png ppds
qt quicktime readline scanner sdl slang ssl tcpd tiff truetype usb xml2 xmms
xprint zlib"
Comment 1 chkno 2005-01-05 03:15:46 UTC
Not specific to hotplug, or to packages in general.  "foo-1.0" gives the same result.

Not specific to files command.  Triggered for all of: check, depgraph, files, size, uses.  (notable exception: list)
Comment 2 Vincent 2005-01-06 03:19:28 UTC
Confirmed. 
I just emerged gentoolkit v0.2.0 today and can reproduce the problem with the "depgraph" option :
$ equery depgraph gentoo-sources-2.4.26-r14
[ Searching for packages matching gentoo-sources-2.4.26-r14... ]
!!! Internal portage error, terminating
Traceback (most recent call last):
  File "/usr/bin/equery", line 1565, in ?
    print_error(e)
  File "/usr/lib/gentoolkit/pym/gentoolkit/pprinter.py", line 14, in print_error
    sys.stderr.write(output.red("!!! ") + s + "\n")
TypeError: cannot concatenate 'str' and 'instance' objects

$ emerge info
Gentoo Base System version 1.4.16
Portage 2.0.51-r3 (default-linux/x86/2004.0, gcc-3.3.4, glibc-2.3.4.20040808-r1, 2.4.22 i686)
=================================================================
System uname: 2.4.22 i686 Celeron (Coppermine)
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.90.0.1.1-r3
Headers:  sys-kernel/linux-headers-2.4.19-r1,sys-kernel/linux-headers-2.4.21-r1
Libtools: sys-devel/libtool-1.4.3-r4,sys-devel/libtool-1.5.2-r7
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=pentium3 -funroll-loops -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium3 -funroll-loops -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms userpriv usersandbox"
GENTOO_MIRRORS="ftp://gentoo.ccccom.com ftp://sunsite.ualberta.ca/pub/unix/Linux/gentoo/ ftp://ftp.isu.edu.tw/pub/Linux/Gentoo ftp://ftp.gtlib.cc.gatech.edu/pub/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d aalib acl apm avi berkdb bitmap-fonts crypt cups dga directfb emacs encode esd fam foomaticdb fortran gd gdbm gif gnome gpm gstreamer gtk gtk2 gtkhtml imap imlib ipv6 java joystick jpeg ldap libg++ libwww mad mikmod mmx motif mozilla mpeg mule ncurses nls oggvorbis opengl oss pam pcmcia pdflib perl plotutils png python quicktime readline samba scanner sdl slang spell sse ssl svga tcpd tetex tiff truetype trusted unicode usb x86 xml xml2 xmms xv zlib"
Comment 3 Søren Chrestensen 2005-01-07 12:37:56 UTC
equery needs a check so when using version you have to use a =. If not using the = equery should complain like emerge does. 
Comment 4 Adam 2005-01-07 13:10:54 UTC
Hmm, it seems like the best approach would be to use the same code to parse the parameters that emerge uses, and link it to both programs or something to ensure that the 2 programs don't behave differently in that respect.
Comment 5 Paul Varner (RETIRED) gentoo-dev 2005-09-16 12:16:30 UTC
Fixed with gentoolkit-0.2.1*
Comment 6 Paul Varner (RETIRED) gentoo-dev 2005-12-16 13:23:35 UTC
*** Bug 115793 has been marked as a duplicate of this bug. ***
Comment 7 Paul Varner (RETIRED) gentoo-dev 2006-01-17 19:27:05 UTC
Fix is in gentoolkit-0.2.1
Comment 8 Harald van Dijk (RETIRED) gentoo-dev 2006-02-25 13:45:41 UTC
*** Bug 124101 has been marked as a duplicate of this bug. ***