Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 766543 - dev-ruby/thor-1.0.1 fails tests
Summary: dev-ruby/thor-1.0.1 fails tests
Status: RESOLVED DUPLICATE of bug 766231
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-22 12:29 UTC by Jonathan Lovelace
Modified: 2021-01-22 12:39 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-ruby:thor-1.0.1:20210122-123152.log (dev-ruby:thor-1.0.1:20210122-123152.log,12.12 KB, text/x-log)
2021-01-22 12:29 UTC, Jonathan Lovelace
Details
emerge-info.txt (emerge-info.txt,7.67 KB, text/plain)
2021-01-22 12:29 UTC, Jonathan Lovelace
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Lovelace 2021-01-22 12:29:11 UTC
Created attachment 684115 [details]
dev-ruby:thor-1.0.1:20210122-123152.log

dev-ruby/thor (both 0.20.3 rebuilding to drop ruby25 support, 0.20.3-r1, and 1.0.1) currently fails a test:

Failures:

  1) when the Thor class's exit_with_failure? method returns true a command that does not raise a Thor::Error exits with a status of 0
     Failure/Error: expect(thor_command("ok")).to eq(0)

       expected: 0
            got: 1

       (compared using ==)
     # ./spec/script_exit_status_spec.rb:27:in `block (2 levels) in <top (required)>'

Finished in 2.36 seconds (files took 0.94625 seconds to load)
755 examples, 1 failure

Failed examples:

rspec ./spec/script_exit_status_spec.rb:26 # when the Thor class's exit_with_failure? method returns true a command that does not raise a Thor::Error exits with a status of 0
Comment 1 Jonathan Lovelace 2021-01-22 12:29:36 UTC
Created attachment 684118 [details]
emerge-info.txt
Comment 2 Ionen Wolkens 2021-01-22 12:33:12 UTC
Does it work if you "eselect ruby set ruby26", it seems to still be trying to use ruby2.5
Comment 3 Jonathan Lovelace 2021-01-22 12:36:37 UTC
Good catch! Yes, that works. Thanks!
Comment 4 Ionen Wolkens 2021-01-22 12:39:10 UTC
Nice.

I'll make this a duplicate for reference, it's still an issue with how effective ruby is handled.

*** This bug has been marked as a duplicate of bug 766231 ***