Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 766438 (CVE-2021-21239) - dev-python/pysaml2: signature verification vulnerability (CVE-2021-21239)
Summary: dev-python/pysaml2: signature verification vulnerability (CVE-2021-21239)
Status: IN_PROGRESS
Alias: CVE-2021-21239
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
URL: https://github.com/IdentityPython/pys...
Whiteboard: B4 [ebuild cve]
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-21 22:50 UTC by John Helmert III
Modified: 2021-01-25 20:16 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Helmert III gentoo-dev Security 2021-01-21 22:50:20 UTC
CVE-2021-21239:

PySAML2 is a pure python implementation of SAML Version 2 Standard.  PySAML2 before 6.5.0 has an improper verification of cryptographic signature vulnerability. Users of pysaml2 that use the default CryptoBackendXmlSec1 backend and need to verify signed SAML documents are impacted. PySAML2 does not ensure that a signed SAML document is correctly signed. The default CryptoBackendXmlSec1 backend is using the xmlsec1 binary to verify the signature of signed SAML documents, but by default xmlsec1 accepts any type of key found within the given document. xmlsec1 needs to be configured explicitly to only use only _x509 certificates_ for the verification process of the SAML document signature.

This is fixed in PySAML2 6.5.0.


Please bump.