Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 76602 - P4 Stage2 tarball is missing files
Summary: P4 Stage2 tarball is missing files
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Release Team
Depends on:
Reported: 2005-01-04 00:27 UTC by John Gonzales
Modified: 2005-01-06 14:18 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description John Gonzales 2005-01-04 00:27:37 UTC
Hi, I was trying to install Gentoo by downloading the stage2 files from a mirror. I downloaded the stage2 file for P4 and found that it was missing the mount command. I came to this conclusion because after I chrooted I could no longer use the command. At first I thought I made a mistake in my install, so I redid everything 3 more times when I finally gave up and tried a stage3 file, which worked flawlessly.

Now maybe the mount command is the only file missing, but I am not too sure, so I think it is worth checking it out.

Reproducible: Always
Steps to Reproduce:
1.Follow the instructions in the Gentoo Handbook up till and including the chroot step.
2.Try using mount to mount a device and you'll get an error message.
*NOTE* This is for the p4 stage2 file
Actual Results:  
file or directory not found

Expected Results:  
It should of mounted the device
Comment 1 Benjamin Judas (RETIRED) gentoo-dev 2005-01-05 00:10:29 UTC
util-linux is not pulled in by a bootstrap. It gets pulled in when running "emerge system" (the transition between stage2 and stage3)
Comment 2 John Gonzales 2005-01-05 17:34:56 UTC
Well I should of also mentioned that I finished a complete install of Gentoo, starting from a stage2 tarball, emerging system and what not, and could not boot up  gentoo because the mount command was not found.
Comment 3 Benjamin Judas (RETIRED) gentoo-dev 2005-01-05 18:45:37 UTC
Did you check if /bin/mount really doesn't exist or did you just try to execute "mount"?
Comment 4 John Gonzales 2005-01-05 23:57:05 UTC
I didn't try anything. When Gentoo tried booting up, it had to mount all the devices I had listed in the fstab which resulted in the error that I got "no such file or directory."

It gave me the option to log into maintenance mode, which didn't do much. I booted up back in with the LiveCD and did what anyone would of done, and that is check whether the file did or did not actually exist. I looked in /bin/bash for the mount command and it was not there.
Comment 5 Benjamin Judas (RETIRED) gentoo-dev 2005-01-06 05:40:32 UTC
It definitely looks like emerge system wasn't completed successfully. I tried to reproduce by running "emerge system" starting from the same stage-file over night and /bin/mount was there and util-linux was pulled in once emerge system was completed. 

I can't reproduce this error.
Comment 6 John Gonzales 2005-01-06 14:18:42 UTC
Well that's good to hear. Maybe it was just an isolated case which only happened to me. I was having some troubles with contacting servers, so that could possibly be it. 

Just for the sake of being sure, I used the following from file from this exact server:

For further documentation of my problem, you can also visit the forum:

It's good to hear though that it worked for you. I have Gentoo working not so there's nothing to worry about anymore. I just thought that it would be worth checking.