Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 765784 - sys-apps/bat-0.17.1-r1 strange warning
Summary: sys-apps/bat-0.17.1-r1 strange warning
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: J Pz
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-17 17:57 UTC by Jonas Stein
Modified: 2021-01-17 18:18 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonas Stein gentoo-dev 2021-01-17 17:57:50 UTC
When installing I read:

"warning: be sure to add `/var/tmp/portage/sys-apps/bat-0.17.1-r1/image/usr/bin` to your PATH to be able to run the installed binaries"

This makes no sense. PATH should not point to /var/tmp 

Reproducible: Always
Comment 1 Georgy Yakovlev gentoo-dev 2021-01-17 18:18:30 UTC
https://github.com/rust-lang/cargo/blob/master/src/cargo/ops/cargo_install.rs


if installed_anything {
        // Print a warning that if this directory isn't in PATH that they won't be
        // able to run these commands.
        let dst = root.join("bin").into_path_unlocked();
        let path = env::var_os("PATH").unwrap_or_default();
        for path in env::split_paths(&path) {
            if path == dst {
                return Ok(());
            }
}


totally harmless, just checks if the installed binaries are in path.
since we install to temporary directory - it's not in path and always triggers warning and not easy to disable without patching.

all rust/cargo packages have this warning.