Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 765739 - sci-libs/amd depends on virtual/fortran even if USE=-fortran
Summary: sci-libs/amd depends on virtual/fortran even if USE=-fortran
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks:
 
Reported: 2021-01-17 13:49 UTC by tka
Modified: 2021-01-17 19:00 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tka 2021-01-17 13:49:11 UTC
# emerge -pv sci-libs/amd

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-devel/gcc-10.2.0-r5:10::gentoo  USE="(cxx) fortran* hardened nptl openmp (pie) sanitize (ssp) test vtv (-ada) -d -debug -doc (-fixed-point) -go -graphite -jit (-libssp) -lto (-multilib) -nls -objc -objc++ -objc-gc (-pch) -pgo -systemtap -vanilla -zstd" 73270 KiB
[ebuild  N     ] virtual/fortran-0::gentoo  USE="openmp" 0 KiB
[ebuild   R    ] sci-libs/amd-2.4.6-r1::gentoo [2.4.6-r1::local] USE="-doc -fortran" 0 KiB

Total: 3 packages (1 new, 2 reinstalls), Size of downloads: 73270 KiB

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by virtual/fortran-0::gentoo
# required by sci-libs/amd-2.4.6-r1::gentoo
# required by sci-libs/amd (argument)
>=sys-devel/gcc-10.2.0-r5 fortran


Reproducible: Always
Comment 1 François Bissey 2021-01-17 19:00:51 UTC
It needs the FORTRAN_NEEDED variable as in the pull request indeed.