Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 765403 - dev-util/herdtools7-7.51 does not respect CFLAGS
Summary: dev-util/herdtools7-7.51 does not respect CFLAGS
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Patrick McLean
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: cflags
  Show dependency tree
 
Reported: 2021-01-14 09:42 UTC by Agostino Sarubbo
Modified: 2021-04-29 18:24 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,130.67 KB, text/plain)
2021-01-14 09:42 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2021-01-14 09:42:50 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: dev-util/herdtools7-7.51 does not respect CFLAGS.
Discovered on: amd64 (internal ref: tinderbox)

NOTE:
To reproduce this issue you may want to add "-frecord-gcc-switches" to CFLAGS/CXXFLAGS/FFLAGS/FCFLAGS. If this is not something about c/c++ context see this bug as an hint to hide the QA warning (with QA_FLAGS_IGNORED) where is not possible to respect CFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2021-01-14 09:42:52 UTC
Created attachment 682837 [details]
build.log

build log and emerge --info
Comment 2 Jakov Smolic 2021-04-29 18:24:16 UTC
CFLAGS are ignored in opam.eclass since https://gitweb.gentoo.org/repo/gentoo.git/commit/eclass/opam.eclass?id=943c9dd81398256b668b81952fab91c4d5c374dc