Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 764779 - sys-libs/libapparmor-3.0.1 : configure: error: python is required when enabling python bindings
Summary: sys-libs/libapparmor-3.0.1 : configure: error: python is required when enabli...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Michael Palimaka (kensington)
URL:
Whiteboard:
Keywords:
: 770937 (view as bug list)
Depends on:
Blocks: 762406
  Show dependency tree
 
Reported: 2021-01-10 10:54 UTC by Toralf Förster
Modified: 2021-05-27 08:23 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.87 KB, text/plain)
2021-01-10 10:54 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,396.76 KB, text/plain)
2021-01-10 10:54 UTC, Toralf Förster
Details
environment (environment,140.02 KB, text/plain)
2021-01-10 10:54 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,30.88 KB, application/x-bzip)
2021-01-10 10:54 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,16.10 KB, application/x-bzip)
2021-01-10 10:54 UTC, Toralf Förster
Details
sys-libs:libapparmor-3.0.1:20210110-070808.log (sys-libs:libapparmor-3.0.1:20210110-070808.log,4.99 KB, text/plain)
2021-01-10 10:54 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-01-10 10:54:01 UTC
checking whether python bindings are enabled... yes
checking for python3... no
configure: error: python is required when enabling python bindings

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-libs/libapparmor-3.0.1/work/apparmor-3.0.1/libraries/libapparmor/config.log

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1-20201231-222458

  -------------------------------------------------------------------

gcc-config -l:
clang version 11.0.1
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/11/bin
/usr/lib/llvm/11
11.0.1
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.9 (fallback)
  [3]   python2.7 (fallback)
  [4]   pypy3 (fallback)
Available Ruby profiles:
  (none found)
Available Rust versions:
  [1]   rust-1.48.0 *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.272_p10 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.8.4

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Sat Jan  9 06:06:52 PM UTC 2021

emerge -qpvO sys-libs/libapparmor
[ebuild  N    ] sys-libs/libapparmor-3.0.1  USE="perl python -doc -static-libs" PYTHON_TARGETS="python3_8 (-python3_6) -python3_7"
Comment 1 Toralf Förster gentoo-dev 2021-01-10 10:54:02 UTC
Created attachment 682204 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-01-10 10:54:04 UTC
Created attachment 682207 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2021-01-10 10:54:05 UTC
Created attachment 682210 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2021-01-10 10:54:07 UTC
Created attachment 682213 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2021-01-10 10:54:08 UTC
Created attachment 682216 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2021-01-10 10:54:09 UTC
Created attachment 682219 [details]
sys-libs:libapparmor-3.0.1:20210110-070808.log
Comment 7 Michael Palimaka (kensington) gentoo-dev 2021-05-27 08:14:01 UTC
*** Bug 770937 has been marked as a duplicate of this bug. ***
Comment 8 Michael Palimaka (kensington) gentoo-dev 2021-05-27 08:14:28 UTC
Apparently this means there's no python3 binary, is that correct?
Comment 9 Agostino Sarubbo gentoo-dev 2021-05-27 08:23:36 UTC
(In reply to Michael Palimaka (kensington) from comment #8)
> Apparently this means there's no python3 binary, is that correct?

correct, see the tracker