Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 764071 - dev-util/android-tools-9.0.0_p3-r1 fails to build with gcc-11 (USE=python)
Summary: dev-util/android-tools-9.0.0_p3-r1 fails to build with gcc-11 (USE=python)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Zac Medico
Keywords: PATCH
: 768471 (view as bug list)
Depends on:
Blocks: gcc-11
  Show dependency tree
Reported: 2021-01-06 09:22 UTC by andy
Modified: 2021-02-12 13:17 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,483.39 KB, text/plain)
2021-01-06 09:22 UTC, andy
protocolcpp_include-gcc11.patch (protocolcpp_include-gcc11.patch,292 bytes, patch)
2021-01-06 09:23 UTC, andy
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description andy 2021-01-06 09:22:10 UTC
Created attachment 681457 [details]

dev-util/android-tools fails to build with gcc-11 with :

core/fastboot/protocol.cpp:250:58: error: ‘numeric_limits’ is not a member of ‘std’
  250 |     int64_t r = _command_start(transport, "upload", std::numeric_limits<int32_t>::max(), nullptr);
      |                                                          ^~~~~~~~~~~~~~
Comment 1 andy 2021-01-06 09:23:35 UTC
Created attachment 681460 [details, diff]
Comment 2 Ionen Wolkens gentoo-dev 2021-01-07 18:02:05 UTC
Just the usual <limits> issue but, to parrot a third time, preferably report with normal *FLAGS anyway. Can reproduce with gcc-11.0.9999-d54be5a.
Comment 3 Ionen Wolkens gentoo-dev 2021-01-07 18:08:28 UTC
This may(?) be fixed upstream (haven't tried), protocol.cpp file was removed entirely:
Comment 4 Sergei Trofimovich (RETIRED) gentoo-dev 2021-01-07 18:46:48 UTC
I think it's triggered by USE=python.
Comment 5 Ionen Wolkens gentoo-dev 2021-01-07 19:01:21 UTC
(In reply to Sergei Trofimovich from comment #4)
> I think it's triggered by USE=python.
Attached log was -python, I tried both USE=python and -python with same results
Comment 6 Kobboi 2021-01-28 22:23:51 UTC
Indeed, failing with -python here too.
Comment 7 Ionen Wolkens gentoo-dev 2021-02-03 10:10:56 UTC
*** Bug 768471 has been marked as a duplicate of this bug. ***
Comment 8 Larry the Git Cow gentoo-dev 2021-02-12 13:17:47 UTC
The bug has been closed via the following commit(s):

commit 8997323e5e0645fc993041d623ccc270e3fe74dc
Author:     Sergei Trofimovich <>
AuthorDate: 2021-02-12 13:17:32 +0000
Commit:     Sergei Trofimovich <>
CommitDate: 2021-02-12 13:17:43 +0000

    dev-util/android-tools: tweak for gcc-11
    Fixed-by: andy
    Package-Manager: Portage-3.0.14, Repoman-3.0.2
    Signed-off-by: Sergei Trofimovich <>

 dev-util/android-tools/android-tools-9.0.0_p3-r1.ebuild       |  4 +++-
 .../files/android-tools-9.0.0-limits-gcc11.patch              | 11 +++++++++++
 2 files changed, 14 insertions(+), 1 deletion(-)