Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 763915 - net-dialup/ppp-2.4.9 calls cc directly
Summary: net-dialup/ppp-2.4.9 calls cc directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2021-01-05 16:12 UTC by Agostino Sarubbo
Modified: 2021-01-05 16:49 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,8.61 KB, text/plain)
2021-01-05 16:12 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2021-01-05 16:12:34 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: net-dialup/ppp-2.4.9 calls cc directly.
Discovered on: amd64 (internal ref: ci)

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different CC implementation (like clang). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the CC variable to x86_64-pc-linux-gnu-gcc.
Comment 1 Agostino Sarubbo gentoo-dev 2021-01-05 16:12:36 UTC
Created attachment 681322 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2021-01-05 16:12:39 UTC
Possible context of error(s):

make[1]: cc: No such file or directory
Comment 3 Larry the Git Cow gentoo-dev 2021-01-05 16:49:05 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c8e50e56b3d003cbcad7c2020fcec3daaf42c43f

commit c8e50e56b3d003cbcad7c2020fcec3daaf42c43f
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2021-01-05 16:48:38 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2021-01-05 16:49:03 +0000

    net-dialup/ppp: Don't call CC directly
    
    Closes: https://bugs.gentoo.org/763915
    Package-Manager: Portage-3.0.12, Repoman-3.0.2
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>

 net-dialup/ppp/Manifest                                  | 2 +-
 net-dialup/ppp/{ppp-2.4.9.ebuild => ppp-2.4.9-r1.ebuild} | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)