Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 76324 - Eterm wouldn't hide borders on xorg-6.8.0
Summary: Eterm wouldn't hide borders on xorg-6.8.0
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: SpanKY
Depends on:
Reported: 2005-01-01 10:14 UTC by Maik Stubbe
Modified: 2005-04-20 22:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

version info (e-stuff,3.51 KB, text/plain)
2005-04-11 10:00 UTC, Tres 'RiverRat' Melton
The fix (eterm-0.9.3-borderless.patch,580 bytes, patch)
2005-04-20 02:26 UTC, Tres 'RiverRat' Melton
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Maik Stubbe 2005-01-01 10:14:27 UTC
Everytime I try to remove the borders on Eterm it does not work. I tried it on fluxbox and gnome. The windowmanager takes no effect. I tried Eterm-0.9.2 and Eterm-0.9.3. Both versions have the same problem so I think it is a problem of xorg

Reproducible: Always
Steps to Reproduce:
1.emerge =xorg-6.8.0-r3
2.emerge =gnome-2.6.2
3.emerge eterm
My eterm user.cfg:
begin toggles
    map_alert 1
    visual_bell 0
    login_shell 1
    scrollbar 0
    utmp_logging 1
    meta8 0
    iconic 0
    home_on_output 1
    home_on_input 1
    no_input 0
    scrollbar_floating 0
    scrollbar_right 1
    scrollbar_popup 0
    borderless 1
    double_buffer 0
    no_cursor 0
    pause 0
    xterm_select 0
    select_line 0
    select_trailing_spaces 1
    report_as_keysyms 0
    itrans 0
    buttonbar 0
    resize_gravity 0
end toggles

start eterm with Eterm -x or Eterm --borderless

Actual Results:  
Eterm starts with borders. It looks like a normal Eterm and the parameter
-x/--borderless takes no effect

Expected Results:  
Eterm should hide the borders instead of showing them
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2005-01-01 15:09:57 UTC
Please use Gentoo -> Component: Ebuilds. Infrastructure is the wrong addressee.
Comment 2 SpanKY gentoo-dev 2005-01-01 15:14:46 UTC
can you try with x11-wm/enlightenment- ?

i use enlightenment as my wm, and -x works with Eterm-0.9.3 / xorg-x11-
Comment 3 Tres 'RiverRat' Melton 2005-04-11 10:00:54 UTC
Created attachment 56000 [details]
version info

Eterm --version
enlightenment --version
esearch enlightenment Eterm
Comment 4 Tres 'RiverRat' Melton 2005-04-11 10:01:21 UTC
This bug is also present on my system: 

I just built this system after upgrading from an x86 machine.  My home directory was simply transferred and it used to work on the old system.

I can hide the border by alt-right-clicking in enlightenment and telling E to hide the border.

I cannot make Eterms open without their borders though.  Eterm --borderless fails; .Eterm/themes/Eterm/user.cfg can't prevent borders; and Eterm -O also fails.

I included the output of Eterm --version, enlightenment --version, and esearch enlightenment Eterm in a small text file (attached).  If there is any more information or anything else to try please ask.
Comment 5 Tres 'RiverRat' Melton 2005-04-20 02:26:46 UTC
Created attachment 56738 [details, diff]
The fix

This fixes the borderless problem.  It also fixes a problem with setting the
title of an Eterm window that I was investigating prior to filing a bug report
(two bugs  with one fix).  No side effects here for the last few hours.

Note to Vapier:  This is only my third patch but it is in a unified diff like
you ask for last time.	I'm trying to do things the Gentoo way so if I screwed
up again please let me know what I did wrong and how to do it right.  It is
against the latest version of Eterm I could find on Gentoo that wasn't hard
masked.  /etc/portage/package.keywords contains:

>=x11-terms/eterm-0.9.3 			~amd64

Thanks in advance for being nice.
Comment 6 SpanKY gentoo-dev 2005-04-20 10:24:16 UTC
the patch looks good, i'll talk to the upstream author about getting it resolved

thanks !
Comment 7 SpanKY gentoo-dev 2005-04-20 16:11:00 UTC
upstream author said patch looks good too so i've committed it both upstream and to portage

thanks Tres :)
Comment 8 Tres 'RiverRat' Melton 2005-04-20 22:02:54 UTC
Well that's a confidence booster.  Glad I could help.