Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 762994 - app-emulation/virtualbox-modules-6.1.18 fails to build with kernel 5.11
Summary: app-emulation/virtualbox-modules-6.1.18 fails to build with kernel 5.11
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Lars Wendler (Polynomial-C)
URL: https://git.kernel.org/pub/scm/linux/...
Whiteboard:
Keywords: PATCH
: 771726 771753 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-01-01 23:59 UTC by jospezial
Modified: 2021-02-23 09:06 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
virtualbox-modules-6.1.16-linux-5.11-VBoxNetFlt-ethtool.patch (virtualbox-modules-6.1.16-linux-5.11-VBoxNetFlt-ethtool.patch,361 bytes, patch)
2021-01-02 00:00 UTC, jospezial
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 jospezial 2021-01-02 00:00:58 UTC
Created attachment 680557 [details, diff]
virtualbox-modules-6.1.16-linux-5.11-VBoxNetFlt-ethtool.patch
Comment 2 jospezial 2021-01-02 21:27:29 UTC
That is my quick'n'dirty patch. Worked for me.
I think it needs changes to be compatible with older kernels.
Tested with winxp32 and manjaro64bit_live VMs.
Comment 3 jospezial 2021-01-20 15:26:16 UTC
This patch is still needed and works for app-emulation/virtualbox-modules-6.1.18 .
https://www.virtualbox.org/ticket/20117
Comment 4 Iade Gesso 2021-02-16 17:44:55 UTC
I can confirm, it's still needed with 5.11.0 kernel and 6.1.18 kernel modules.

Iade
Comment 5 jospezial 2021-02-16 18:37:45 UTC
upstream duplicate ticket
https://www.virtualbox.org/ticket/20193
Comment 6 jospezial 2021-02-18 10:56:58 UTC
https://www.virtualbox.org/ticket/20198
active upstream duplicate ticket

Next 6.1.x release will have the fix.
Comment 7 Ionen Wolkens 2021-02-20 21:18:07 UTC
*** Bug 771726 has been marked as a duplicate of this bug. ***
Comment 8 Arnd Feldmueller 2021-02-22 19:29:23 UTC
(In reply to jospezial from comment #6)
> https://www.virtualbox.org/ticket/20198
> active upstream duplicate ticket
> 
> Next 6.1.x release will have the fix.

When? In few weeks?
Comment 9 Larry the Git Cow gentoo-dev 2021-02-22 19:53:30 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f9d40ea3a468742fafb3dc6cd5071ba1126b5133

commit f9d40ea3a468742fafb3dc6cd5071ba1126b5133
Author:     Louis Sautier <sbraz@gentoo.org>
AuthorDate: 2021-02-22 19:50:21 +0000
Commit:     Louis Sautier <sbraz@gentoo.org>
CommitDate: 2021-02-22 19:53:05 +0000

    app-emulation/virtualbox-modules: fix build with kernel 5.11
    
    Closes: https://bugs.gentoo.org/762994
    Package-Manager: Portage-3.0.14, Repoman-3.0.2
    Signed-off-by: Louis Sautier <sbraz@gentoo.org>

 .../files/virtualbox-modules-6.1.18-kernel-5.11.ebuild   | 16 ++++++++++++++++
 .../virtualbox-modules/virtualbox-modules-6.1.18.ebuild  |  4 ++++
 2 files changed, 20 insertions(+)
Comment 10 Louis Sautier (sbraz) gentoo-dev 2021-02-22 19:56:17 UTC
*** Bug 771753 has been marked as a duplicate of this bug. ***
Comment 11 jospezial 2021-02-22 21:36:11 UTC
(In reply to Larry the Git Cow from comment #9)
> The bug has been closed via the following commit(s):
> 
> https://gitweb.gentoo.org/repo/gentoo.git/commit/
> ?id=f9d40ea3a468742fafb3dc6cd5071ba1126b5133
> 
> commit f9d40ea3a468742fafb3dc6cd5071ba1126b5133
> Author:     Louis Sautier <sbraz@gentoo.org>
> AuthorDate: 2021-02-22 19:50:21 +0000
> Commit:     Louis Sautier <sbraz@gentoo.org>
> CommitDate: 2021-02-22 19:53:05 +0000
> 
>     app-emulation/virtualbox-modules: fix build with kernel 5.11
>     
>     Closes: https://bugs.gentoo.org/762994
>     Package-Manager: Portage-3.0.14, Repoman-3.0.2
>     Signed-off-by: Louis Sautier <sbraz@gentoo.org>
> 
>  .../files/virtualbox-modules-6.1.18-kernel-5.11.ebuild   | 16
> ++++++++++++++++
>  .../virtualbox-modules/virtualbox-modules-6.1.18.ebuild  |  4 ++++
>  2 files changed, 20 insertions(+)

You gave the patch the .ebuild extension. Please rename!