Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 762778 - app-emulation/dosemu-1.4.1_pre20130107-r5 calls nm directly
Summary: app-emulation/dosemu-1.4.1_pre20130107-r5 calls nm directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sergei Trofimovich
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-12-31 11:42 UTC by Agostino Sarubbo
Modified: 2020-12-31 14:00 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,195.57 KB, text/plain)
2020-12-31 11:42 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-12-31 11:42:03 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: app-emulation/dosemu-1.4.1_pre20130107-r5 calls nm directly.
Discovered on: amd64 (internal ref: ci)

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different NM implementation (like llvm-nm). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the NM variable to x86_64-pc-linux-gnu-nm.
Comment 1 Agostino Sarubbo gentoo-dev 2020-12-31 11:42:06 UTC
Created attachment 680422 [details]
build.log

build log and emerge --info
Comment 2 Larry the Git Cow gentoo-dev 2020-12-31 14:00:55 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0e56106a0e898af399438fefd237e1479ce0ef85

commit 0e56106a0e898af399438fefd237e1479ce0ef85
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-12-31 14:00:33 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-12-31 14:00:49 +0000

    app-emulation/dosemu: lookup tool-prefixed nm
    
    While at it allow user's NM.
    
    Reported-by: Agostino Sarubbo
    Closes: https://bugs.gentoo.org/762778
    Package-Manager: Portage-3.0.12, Repoman-3.0.2
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 .../dosemu/dosemu-1.4.1_pre20130107-r5.ebuild      |  1 +
 .../dosemu/files/dosemu-1.4.1_pre20130107-nm.patch | 44 ++++++++++++++++++++++
 2 files changed, 45 insertions(+)