Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 7615 - XGalaga sound doesn't work for some users
Summary: XGalaga sound doesn't work for some users
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Games
Depends on:
Reported: 2002-09-07 08:58 UTC by Decibels
Modified: 2011-09-14 20:37 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Decibels 2002-09-07 08:58:14 UTC
I posted this on the forum hoping someone had an answer, but didn't.
The problem is:
xgalaga version 2.0.34-r2
The Spacebar doesn't work for the User. Works fine as
Doesn't appear to be an permissions problem, cause the user owns the binary
and is in the group.
Comment 1 José Alberto Suárez López 2002-09-07 19:22:41 UTC
really strange..
Comment 2 Decibels 2002-10-12 08:50:36 UTC
Trying to install a 1.4rc1 system. While waiting for for something to compile, I
installed xgalaga.

Spacebar firing works as User in the 1.4rc1 system using Gcc3.2.
So went back to the 1.2 system and unmerged and re-emerged xgalaga and
spacebar firing still doesn't work for the 1.2 system.

I would say forget it and just use it on the 1.4rc1 system, but that isn't going
to well.

Using flags on 1.2 system:
CFLAGS="-march=i686 -O3 -pipe"
CXXFLAGS="-march=i686 -O3 -pipe"

Using flags on 1.4rc1 system:
CFLAGS="-mcpu=athlon -O3 -pipe"

Hope this helps solve this dilemma.
CXXFLAGS="-march=i686 -O3 -pipe"
Comment 3 Decibels 2002-10-12 09:00:11 UTC
Ignore the extra: CXXFLAGS="-march=i686 -O3 -pipe"
on the end, mistake.
Comment 4 Decibels 2002-10-21 22:12:05 UTC
Just thought of something so tried it out.
XGalaga will work fine for the User in Gnome, but not KDE.
When I posted before that I had it working in 1.4rc1 system, I was
trying Gnome out. I still have it on the system so tested it out.

Hope this helps.
Comment 5 José Alberto Suárez López 2002-12-14 15:37:39 UTC
sorry, i don't have kde to reproduce this bug, other game-team guy do it.
Comment 6 Seemant Kulleen (RETIRED) gentoo-dev 2002-12-23 03:40:32 UTC
Debian's patch to this fixes this issue.  Basically, before the patch, the
spacebar works IF you have numlock turned OFF.  Annoying, and upstream should
really start maintaining this package, but oh well.
Comment 7 Decibels 2002-12-23 07:59:16 UTC
I confirm. Thanks, at least a work around.
Comment 8 SpanKY gentoo-dev 2002-12-23 11:14:46 UTC
thx dad ;) 
i havent been back to my desktop computer for about 2 weeks so i wasnt able to test this ;) 
Comment 9 Decibels 2002-12-23 12:29:40 UTC
Looks like the problem taken care of even with the numlock on for
the new ebuild. I don't have any sound for some reason, but the bug
is fixed.
Comment 10 Seemant Kulleen (RETIRED) gentoo-dev 2002-12-23 12:38:18 UTC
yes, the new ebuild was designed to fix the keyboard issue.  The sound issue is
one I am not sure of, but I'll investigate into, if the games team does not.

Does sound work as root?
Comment 11 Decibels 2002-12-23 12:55:45 UTC
I am compiling the security update for kde so could only do it with
kdesu right now. And with that sound didn't work! I don't think it
will make a difference, but will change to root login and try it after the
update of kde is done and I put modutils-2.4.20 back from 2.4.22 so
my usb mouse works. 
Comment 12 Decibels 2002-12-23 22:31:36 UTC
Okay, tested it out. Noticed when logged out of user to login in as root, that
xgalaga sounds started. Pretty funny, it actually saved the audio even after
hours of recompiling the new kde.  This was before actually got to login screen,
then you get the normal arts not working will use /dev/null when starts up Kde.
 Rebooted to clear everything and start fresh.

Tested as root from login and same as user. Sounds only when logout.
Using arts for sound deamon.
Comment 13 SpanKY gentoo-dev 2002-12-24 07:28:17 UTC
does sound not work at all or only for the game ? <- for general sound setup in ALSA 
Comment 14 Decibels 2002-12-24 08:19:24 UTC
Don't use alsa. Sound works fine (arts)! Just like I heard your email come in on
I did hear xgalaga sounds when I log off, like I said, kinda of weird how it
saved the sounds and they play when leaving kde.
Comment 15 Decibels 2003-01-31 12:50:55 UTC
Hey, I tried something and this worked.
I know the way to fix it.
The game is installed with root as user and group.
Changing the group to games. Which the user is part of 
Sound is restored for User.

Just thought of this when working on a K3b permissions problem.
Comment 16 SpanKY gentoo-dev 2003-01-31 16:50:09 UTC

*** This bug has been marked as a duplicate of 14218 ***
Comment 17 Decibels 2003-01-31 19:13:58 UTC
Not to be a pest, but how can this be a duplicate of bugno 14218 and then bug 14218 turn around and be a duplicate of 7615. That is just a loop and ends no where except to say it isn't going to be fix/fixable.
Comment 18 SpanKY gentoo-dev 2003-01-31 19:16:47 UTC
umm bug 14218 is not a dup of bug 7615 ... 
Comment 19 Decibels 2003-01-31 19:20:14 UTC
Not sure if your stating a fact or just making an observation. But if it is a fact, then clicking on bugno for this is a duplicate here will take you to 14218, then it is marked as a duplicate of 7615 and will take you back here. 
Comment 20 SpanKY gentoo-dev 2003-01-31 19:34:41 UTC
read the last comment on bug 14218 ... and then keep re-reading it until it makes 
Comment 21 Mr. Bones. (RETIRED) gentoo-dev 2005-05-19 09:06:06 UTC
Closing to clean up after bugzilla upgrade.  reopen if closed in error.  Thanks.
Comment 22 Mr. Bones. (RETIRED) gentoo-dev 2011-09-14 20:37:24 UTC
clean up bug list after bugzilla update