Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 761286 - net-wireless/broadcom-sta-6.30.223.271-r6 fails to build with linux-5.10
Summary: net-wireless/broadcom-sta-6.30.223.271-r6 fails to build with linux-5.10
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major with 1 vote (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL: https://raw.githubusercontent.com/arc...
Whiteboard:
Keywords: PATCH
Depends on: 751211
Blocks:
  Show dependency tree
 
Reported: 2020-12-22 21:58 UTC by tka
Modified: 2021-02-12 04:45 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,13.96 KB, text/plain)
2020-12-22 21:59 UTC, tka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tka 2020-12-22 21:58:53 UTC
Even after applying the patch from bug 751211 for compatibility with linux-5.9, compiling broadcom-sta-6.30.223.271-r6 for linux-5.10 fails (again):

  CC [M]  /var/tmp/portage/net-wireless/broadcom-sta-6.30.223.271-r6/work/src/wl/sys/wl_cfg80211_hybrid.o
/var/tmp/portage/net-wireless/broadcom-sta-6.30.223.271-r6/work/src/wl/sys/wl_cfg80211_hybrid.c: In function 'wl_dev_ioctl':
/var/tmp/portage/net-wireless/broadcom-sta-6.30.223.271-r6/work/src/wl/sys/wl_cfg80211_hybrid.c:460:7: error: implicit declaration of function 'get_fs'; did you mean 'get_ds'? [-Werror=implicit-function-declaration]
  460 |  fs = get_fs();
      |       ^~~~~~
      |       get_ds
/var/tmp/portage/net-wireless/broadcom-sta-6.30.223.271-r6/work/src/wl/sys/wl_cfg80211_hybrid.c:460:7: error: incompatible types when assigning to type 'mm_segment_t' from type 'int'
/var/tmp/portage/net-wireless/broadcom-sta-6.30.223.271-r6/work/src/wl/sys/wl_cfg80211_hybrid.c:461:2: error: implicit declaration of function 'set_fs'; did you mean 'sget_fc'? [-Werror=implicit-function-declaration]
  461 |  set_fs(get_ds());
      |  ^~~~~~
      |  sget_fc
In file included from /var/tmp/portage/net-wireless/broadcom-sta-6.30.223.271-r6/work/src/wl/sys/wl_cfg80211_hybrid.c:26:
/var/tmp/portage/net-wireless/broadcom-sta-6.30.223.271-r6/work/src/include/linuxver.h:596:19: error: 'KERNEL_DS' undeclared (first use in this function); did you mean 'KERNFS_NS'?
  596 | #define get_ds() (KERNEL_DS)
      |                   ^~~~~~~~~
/var/tmp/portage/net-wireless/broadcom-sta-6.30.223.271-r6/work/src/wl/sys/wl_cfg80211_hybrid.c:461:9: note: in expansion of macro 'get_ds'
  461 |  set_fs(get_ds());
      |         ^~~~~~
/var/tmp/portage/net-wireless/broadcom-sta-6.30.223.271-r6/work/src/include/linuxver.h:596:19: note: each undeclared identifier is reported only once for each function it appears in
  596 | #define get_ds() (KERNEL_DS)
      |                   ^~~~~~~~~
/var/tmp/portage/net-wireless/broadcom-sta-6.30.223.271-r6/work/src/wl/sys/wl_cfg80211_hybrid.c:461:9: note: in expansion of macro 'get_ds'
  461 |  set_fs(get_ds());
      |         ^~~~~~
In file included from /var/tmp/portage/net-wireless/broadcom-sta-6.30.223.271-r6/work/src/wl/sys/wl_cfg80211_hybrid.c:43:
/var/tmp/portage/net-wireless/broadcom-sta-6.30.223.271-r6/work/src/wl/sys/wl_cfg80211_hybrid.c: In function 'wl_set_auth_type':
/var/tmp/portage/net-wireless/broadcom-sta-6.30.223.271-r6/work/src/wl/sys/wl_cfg80211_hybrid.h:52:5: warning: this statement may fall through [-Wimplicit-fallthrough=]
   52 |  if (wl_dbg_level & WL_DBG_DBG) {   \
      |     ^
/var/tmp/portage/net-wireless/broadcom-sta-6.30.223.271-r6/work/src/wl/sys/wl_cfg80211_hybrid.c:815:3: note: in expansion of macro 'WL_DBG'
  815 |   WL_DBG(("network eap\n"));
      |   ^~~~~~
/var/tmp/portage/net-wireless/broadcom-sta-6.30.223.271-r6/work/src/wl/sys/wl_cfg80211_hybrid.c:816:2: note: here
  816 |  default:
      |  ^~~~~~~
cc1: some warnings being treated as errors
make[1]: *** [scripts/Makefile.build:279: /var/tmp/portage/net-wireless/broadcom-sta-6.30.223.271-r6/work/src/wl/sys/wl_cfg80211_hybrid.o] Error 1
make: *** [Makefile:1805: /var/tmp/portage/net-wireless/broadcom-sta-6.30.223.271-r6/work] Error 2
make: Leaving directory '/usr/src/linux-5.10'
 * ERROR: net-wireless/broadcom-sta-6.30.223.271-r6::gentoo failed (compile phase):
 *   emake failed


Reproducible: Always
Comment 1 tka 2020-12-22 21:59:59 UTC
Created attachment 679248 [details]
build.log

# emerge -pqv '=net-wireless/broadcom-sta-6.30.223.271-r6::gentoo'
[ebuild   R   ] net-wireless/broadcom-sta-6.30.223.271-r6 


# emerge --info '=net-wireless/broadcom-sta-6.30.223.271-r6::gentoo'
Portage 3.0.12 (python 3.8.7-final-0, default/linux/amd64/17.1/no-multilib/hardened, gcc-10.2.0, glibc-2.32-r5, 5.9.16 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.9.16-x86_64-Intel-R-_Core-TM-_i7-4810MQ_CPU_@_2.80GHz-with-glibc2.2.5
KiB Mem:    16292308 total,   5910152 free
KiB Swap:   20971516 total,  20971260 free
Timestamp of repository gentoo: Tue, 22 Dec 2020 21:00:01 +0000
Head commit of repository gentoo: 09b8f71a2bea30bd2ef3dfef0777d7da50ea1bfa
sh bash 5.1_p4
ld GNU ld (Gentoo 2.35.1 p2) 2.35.1
app-shells/bash:          5.1_p4::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.30.3-r1::gentoo
dev-lang/python:          3.7.9-r1::gentoo, 3.8.7::gentoo, 3.9.1::gentoo
dev-util/cmake:           3.19.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7-r1::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.20::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.3-r1::gentoo
sys-devel/binutils:       2.35.1-r1::gentoo
sys-devel/gcc:            10.2.0-r4::gentoo
sys-devel/gcc-config:     2.3.2-r1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.32-r5::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-max-age: 24
    sync-rsync-extra-opts: --new-compress
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1

local
    location: /var/lib/portage-local/local
    masters: gentoo
    priority: 0

testing
    location: /var/lib/portage-local/testing
    masters: gentoo
    priority: 1

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -mtune=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -mtune=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs cgroup collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
LINGUAS=""
MAKEOPTS="-j8"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--new-compress"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 acl acpi alsa amd64 avx bzip2 cairo caps cdda cddb cdparanoia crypt cups dbus dri dts dvd elogind fam ffmpeg fftw flac fontconfig gif gimp gmp gnutls gtk hardened iconv icu idn ipv6 jpeg lame lcms libglvnd libnotify libtirpc lzma mad matroska mmap mmx mmxext mp3 mpeg ncurses networkmanager nptl ogg opengl openmp pam pcre pie png policykit ppds readline sasl sdl seccomp split-usr sse sse2 sse3 sse4 sse4_1 sse4_2 ssl ssp ssse3 startup-notification svg test theora threads tiff truetype udev udisks unicode upower vaapi vorbis wayland x264 xattr xcb xinerama xml xtpax xv xvid zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt rdrand sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2 php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_8" PYTHON_TARGETS="python2_7 python3_8" RUBY_TARGETS="ruby25 ruby26" USERLAND="GNU" VIDEO_CARDS="i965 intel nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS

=================================================================
                        Package Settings
=================================================================

net-wireless/broadcom-sta-6.30.223.271-r6::gentoo was built with the following:
USE=""
Comment 2 strawman2511 2020-12-26 11:01:31 UTC
I think I have the same problem too. But I don't build it from broadcom-sta ebuild. I compile my own broadcom-wl driver for myself. Link over here: https://github.com/antoineco/broadcom-wl

Old Linux kernel version it work pretty well. Except for the new Linux Kernel 5.10

`broadcom-wl` in Arch also have the same problem.
https://bugs.archlinux.org/task/69045

I think that the problem is Broadcom seem don't write new broadcom driver for Linux kernel 5.10 so we need to patch it if we want broadcom wireless work.

I don't sure if I can patch this. I just a newbie come to open source who try to learn C anyway. But if I can, I will try my best.
Comment 3 tka 2021-01-09 14:36:56 UTC
Arch Linux has a patch, which can be found at https://raw.githubusercontent.com/archlinux/svntogit-community/f5bb5d3bff311ff48d36061b249a472098fed968/trunk/011-linux59.patch

Actually, this is a patch that establishes compatibility with linux-5.9 and linux-5.10. The other patch for linux-5.9 mentioned in bug #751211 is no longer needed and conflicts with this one.
Comment 4 Azamat H. Hackimov 2021-01-12 09:25:52 UTC
Isn't patch https://raw.githubusercontent.com/archlinux/svntogit-community/f5bb5d3bff311ff48d36061b249a472098fed968/trunk/011-linux59.patch breaks compatibility with kernel < 5.9?
Comment 5 Nikolay Kichukov 2021-01-29 16:06:37 UTC
Thanks, the patch worked on 5.10.10 gentoo kernel.
Comment 6 Mustafa 2021-02-12 04:45:58 UTC
Now I have the same problem with linux-5.10.15 :(