Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 760501 - app-i18n/fcitx-5 version bump
Summary: app-i18n/fcitx-5 version bump
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 7 votes (vote)
Assignee: Arfrever Frehtes Taifersar Arahesis
URL: https://github.com/fcitx/fcitx5
Whiteboard:
Keywords:
: 872794 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-12-17 17:15 UTC by Chang Liu
Modified: 2022-11-18 02:49 UTC (History)
15 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chang Liu 2020-12-17 17:15:36 UTC
Fcitx5 has been offical released, and it is availabe in Arch.
https://www.archlinux.org/packages/community/x86_64/fcitx5/

It is also avaialbe in gentoo-zh overlay.
https://github.com/microcai/gentoo-zh

Previous it depends on cldr-emoji-annotation, which is in conflict with gentoo package unicode-cldr. Now the author has added the ability to depends on any cldr provider. Arch has already taken steps to follow that and replace cldr-emoji-annotation with unicode-cldr.

Reproducible: Always
Comment 1 Arfrever Frehtes Taifersar Arahesis 2020-12-17 19:45:38 UTC
I am slowly working on ebuilds of Fcitx 5 and on other things...

In Gentoo, packages of Fcitx 5 will not have "5" in package name, but will use SLOT="5". Examples:
> app-i18n/fcitx       SLOT="5"  (https://github.com/fcitx/fcitx5)
> app-i18n/fcitx-gtk   SLOT="5"  (https://github.com/fcitx/fcitx5-gtk)
> app-i18n/fcitx-qt    SLOT="5"  (https://github.com/fcitx/fcitx5-qt)
> app-i18n/fcitx-rime  SLOT="5"  (https://github.com/fcitx/fcitx5-rime)

Fcitx 5 currently consists of about 22 or 23 packages at upstream level (22 + Fcitx fork of Mozc). gentoo-zh contains 8 of them.

I hope to add at least majority of these 22 packages in this month.
Comment 2 Chang Liu 2020-12-17 20:34:42 UTC
(In reply to Arfrever Frehtes Taifersar Arahesis from comment #1)

Thank you for your hard work. I think you can start with the most used ones. A good reference is

https://pkgstats.archlinux.de/packages#query=fcitx5
Comment 3 Tobias Jakobi 2021-07-02 23:05:49 UTC
Any news on this one?
Comment 4 Jae Hak Kim 2021-08-04 09:45:57 UTC
I've just submitted fcitx5-hangul ebuild to gentoo-zh

https://github.com/microcai/gentoo-zh/blob/master/app-i18n/fcitx5-hangul/fcitx5-hangul-5.0.3.ebuild
Comment 5 anonymous 2021-09-17 13:19:46 UTC
fcitx5 is necessary for wayland support.
Comment 6 Jae Hak Kim 2022-06-02 01:26:08 UTC
FYI, fcitx5 ebuilds in gentoo-zh overlay has been updated to use SLOT.

https://github.com/microcai/gentoo-zh/tree/master/app-i18n
Comment 7 Ryan Qian 2022-06-03 10:10:35 UTC
(In reply to Jae Hak Kim from comment #6)
> FYI, fcitx5 ebuilds in gentoo-zh overlay has been updated to use SLOT.
> 
> https://github.com/microcai/gentoo-zh/tree/master/app-i18n

Yeap, but pay attention that the fcitx:5, fcitx-configtools:5, fcitx-rime:5, and so on have icon files conflicts with fcitx:4.
Comment 8 Matthew Smith gentoo-dev 2022-09-25 09:25:59 UTC
*** Bug 872794 has been marked as a duplicate of this bug. ***
Comment 9 Jesse 2022-11-18 02:49:28 UTC
Fcitx5 was official release for 1 year. Many distros have adopted it even Debian
https://github.com/fcitx/fcitx5/tags
As I see our version has stayed at 4.9999 https://packages.gentoo.org/packages/app-i18n/fcitx
Fcitx5 has fewer dependencies compared to Ibus, it's compatible better with Flatpak apps, and it supports Wayland better. Maybe it's a new IME compare to old Fcitx. But you could use SLOT as Gentoo-zh overlay did, then we can have 2 versions in the same repo, and user are free to pick it.
Please make the bump happened in the official repo. Please!