Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 760468 - =sys-cluster/slurm-20.11.0.1: missing dependency on dev-libs/glib:2
Summary: =sys-cluster/slurm-20.11.0.1: missing dependency on dev-libs/glib:2
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Alexey Shvetsov
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-17 13:23 UTC by Marek Szuba
Modified: 2021-01-05 15:19 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Szuba gentoo-dev 2020-12-17 13:23:05 UTC
When building Slurm on a clean system (e.g. using puremerge), its prepare phase fails with the following error:

 * Running autoconf --force ...                                                                               [ !! ]
  
 * Failed Running autoconf !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/sys-cluster/slurm-20.11.0.1-r100/temp/autoconf.out

 * ERROR: sys-cluster/slurm-20.11.0.1-r100::local failed (prepare phase):


whereas the aforementioned autoconf.out file reports:

***** autoconf *****
***** PWD: /var/tmp/portage/sys-cluster/slurm-20.11.0.1-r100/work/slurm-slurm-20-11-0-1
***** autoconf --force

configure.ac:259: error: possibly undefined macro: AM_PATH_GLIB_2_0
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.



The macro AM_PATH_GLIB_2_0 comes from aclocal files installed by dev-libs/glib:2 , and with that package present Slurm emerges fine.
Comment 1 Marek Szuba gentoo-dev 2020-12-17 13:52:52 UTC
(ignore the -r100 bit in emerge output, I have tried this -r0 as well with the same result)
Comment 2 Larry the Git Cow gentoo-dev 2020-12-17 13:54:24 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=53b559b7358366581882f69cdcfbf5366475c1c6

commit 53b559b7358366581882f69cdcfbf5366475c1c6
Author:     Marek Szuba <marecki@gentoo.org>
AuthorDate: 2020-12-17 13:48:15 +0000
Commit:     Marek Szuba <marecki@gentoo.org>
CommitDate: 2020-12-17 13:54:14 +0000

    sys-cluster/slurm: migrate to lua-single.eclass
    
    Version compatibility as per upstream build scripts. Includes fixes
    for Bugs: 760465 (the applied patch + 'use_enable lua' in src_configure)
    and 760468 (dev-libs/glib:2 in COMMON_DEPEND), both should be directly
    applicable to the unmigrated ebuild as well. Still vulnerable to Bug
    631552.
    
    Closes: https://bugs.gentoo.org/752867
    Bug: https://bugs.gentoo.org/760465
    Bug: https://bugs.gentoo.org/760468
    Signed-off-by: Marek Szuba <marecki@gentoo.org>

 profiles/package.mask                              |   1 +
 .../slurm/files/slurm-20.11.0.1_autoconf-lua.patch |  50 ++++
 sys-cluster/slurm/slurm-20.11.0.1-r100.ebuild      | 269 +++++++++++++++++++++
 3 files changed, 320 insertions(+)