Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 7604 - gentoo-sources-2.4.19-r9 does not build with CryptoAPI
Summary: gentoo-sources-2.4.19-r9 does not build with CryptoAPI
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Brandon Low (RETIRED)
Depends on:
Reported: 2002-09-07 02:58 UTC by Gert Thiel
Modified: 2003-01-28 00:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Gert Thiel 2002-09-07 02:58:54 UTC
I tried to build gentoo-sources-2.4.19-r9 with the InternationalKenerl Patch  
(CryptoAPI) and included USE=crypto.  
The build fails with both gcc 2.95.3 and gcc 3.2 while parsing line 197 of  
/usr/src/linux/include/linux/skbuff.h which reads:  
gcc 2.95.3 says:  
/usr/src/linux-2.4.19-gentoo-r9/include/linux/skbuff.h:197: `defined' without  
an identifier  
/usr/src/linux-2.4.19-gentoo-r9/include/linux/skbuff.h:197: parse error  
gcc 3.2 says:  
/usr/src/linux-2.4.19-gentoo-r9/include/linux/skbuff.h:197:32: missing ')'  
after "defined" 
TIA. Gert.
Comment 1 Thomas Bullinger 2002-09-07 11:05:29 UTC
I see the same issue with that ebuild - but only if the "crypto" USE flag is

Even a change of the line in skbuff.h to "#ifdef ( ... )" doesn't help - it only
opens up other problems (gcc 2.95.3).
Comment 2 Brandon Low (RETIRED) gentoo-dev 2002-09-07 22:47:55 UTC
the line should be 
#if ( defined CONFIG_NETFILTER || defined CONFIG_IPSEC )
I believe, if you could test this and see what all goes on that would be cool...
Comment 3 Gert Thiel 2002-09-08 01:50:31 UTC
make bzImage worked with  
#if ( defined CONFIG_NETFILTER || defined CONFIG_IPSEC )  
no further tests yet - I'm compiling the modules now.  
Thanks. Gert.  
BTW. Maybe we should search for more of these wrong pre-processor statements? 
Comment 4 Gert Thiel 2002-09-08 23:26:42 UTC
Compiled kernel now in service. Good. 
Comment 5 Brandon Low (RETIRED) gentoo-dev 2002-09-08 23:37:33 UTC
I think that is the only wrong one, and I ahve it corrected now with a patch in
for the latest CVS version of gentoo-sources-2.4.19-r9 :)  Thanks for your help
in testing :)