Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 759256 - www-client/chromium: DEPEND on freetype[png]
Summary: www-client/chromium: DEPEND on freetype[png]
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Chromium Project
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks:
 
Reported: 2020-12-09 17:49 UTC by William Breathitt Gray
Modified: 2020-12-09 20:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description William Breathitt Gray 2020-12-09 17:49:09 UTC
Some fonts (e.g. media-libs/noto-emoji) requires freetype with png support enabled in order to display properly in web browsers such as chromium. Adding DEPEND="media-libs/freetype[png]:=" to the chromium ebuild should resolve this issue.

See https://bugs.gentoo.org/753569 for why this was not added in the noto-emoji ebuild.

Reproducible: Always
Comment 1 Ionen Wolkens gentoo-dev 2020-12-09 19:00:33 UTC
This applies to about anything that can use those fonts.
e.g. if I disable freetype[png] I can't see noto-emoji in xfce4-terminal anymore

But does that mean xfce4-terminal (or its deps used to render fonts), need to depend on freetype[png] now? For an optional font people may not be using?

I see this as the equivalent of disabling USE=jpeg on a package and wondering why jpeg images aren't showing anymore. USE=png isn't a desktop profile default for nothing.

Not that it's up to me, maybe maintainer will think otherwise.
Comment 2 Stephan Hartmann gentoo-dev 2020-12-09 20:19:57 UTC
This can't be solved by adding a USE dependency on media-libs/freetype[png], because chromium does not require it to build (or possibly any other application). I think the right approach here is to add an elog to media-libs/noto-emoji informing users to install media-libs/freetype with png support to work correctly in other applications (web browsers, terminals, ...). I therefore suggest to reopen bug #753569.