Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 759166 - x11-libs/pango-1.42.4-r2: /bin/sh: line 1: /usr/x86_64-multilib-linux-gnu/usr/bin/glib-mkenums: No such file or directory
Summary: x11-libs/pango-1.42.4-r2: /bin/sh: line 1: /usr/x86_64-multilib-linux-gnu/usr...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: crossdev-bugs
  Show dependency tree
 
Reported: 2020-12-09 01:08 UTC by Aisha Tammy
Modified: 2021-04-18 14:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
x86_64-multilib-linux-gnu-emerge --info (x86_64-multilib-linux-gnu-emerge --info.txt,5.18 KB, text/plain)
2020-12-09 01:08 UTC, Aisha Tammy
Details
build.log (build.log,15.36 KB, text/x-log)
2020-12-09 01:09 UTC, Aisha Tammy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aisha Tammy 2020-12-09 01:08:35 UTC
Created attachment 677365 [details]
x86_64-multilib-linux-gnu-emerge --info

compilation fails on a crossdev compile for amd64

It seems to be calling the executable from inside the portage root, which would not have worked, even if it were present...
Comment 1 Aisha Tammy 2020-12-09 01:09:02 UTC
Created attachment 677368 [details]
build.log
Comment 2 Aisha Tammy 2020-12-09 01:18:04 UTC
The error is in the configure.ac script - line 475:

> GLIB_MKENUMS=`$PKG_CONFIG --variable=glib_mkenums glib-2.0`

It is using PKG_CONFIG which substitutes to CHOST pkg-config, instead it should be using the CBUILD's pkgconfig...

<rant>
i'm about to throw someone into the gutter and light somebody's pants on fire, crossdev makes me want to stab someone with some bananas and drown them in fruit salad.
</rant>
Comment 3 Ionen Wolkens 2020-12-09 02:03:08 UTC
Does pango-1.44.7 work? I always welcome more reasons to complaint that it's still masked.

It uses meson, so the configure.ac is gone.
Comment 4 Aisha Tammy 2020-12-09 02:44:31 UTC
Yes, 1.44.7 compiles. I unmasked it locally and it merged fine.
Comment 5 Matt Turner gentoo-dev 2021-04-18 14:03:36 UTC
Yes, this is broken in EAPI < 7. Not planning to touch pango-1.42.