Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 759100 - app-emulation/virtualbox-guest-additions-6.1.34-r2 does not respect LDFLAGS
Summary: app-emulation/virtualbox-guest-additions-6.1.34-r2 does not respect LDFLAGS
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Viorel
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: ldflags
  Show dependency tree
 
Reported: 2020-12-08 18:44 UTC by Agostino Sarubbo
Modified: 2022-07-10 22:51 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.xz (build.log.xz,92.59 KB, application/x-xz)
2020-12-08 18:44 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-12-08 18:44:42 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: app-emulation/virtualbox-guest-additions-6.1.16-r1 does not respect LDFLAGS.
Discovered on: amd64 (internal ref: ci)

NOTE:
To reproduce this issue you may want to set LDFLAGS="${LDFLAGS} -Wl,--defsym=__gentoo_check_ldflags__=0". If this is not something about c/c++ context you may want to see this bug as an hint to hide the QA warning (with QA_FLAGS_IGNORED) where is not possible to respect LDFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2020-12-08 18:44:46 UTC
Created attachment 677272 [details]
build.log.xz

build log and emerge --info (compressed because it exceeds attachment limit, use 'xzless' to read it)
Comment 2 Agostino Sarubbo gentoo-dev 2021-12-13 08:21:36 UTC
tinderbox has reproduced this issue with version 6.1.30 - Updating summary.
Comment 3 Agostino Sarubbo gentoo-dev 2022-05-16 05:55:36 UTC
ci has reproduced this issue with version 6.1.34 - Updating summary.
Comment 4 Agostino Sarubbo gentoo-dev 2022-05-28 16:28:59 UTC
ci has reproduced this issue with version 6.1.34-r1 - Updating summary.
Comment 5 Larry the Git Cow gentoo-dev 2022-07-06 09:04:25 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=dccb419d713441f745564eadfab23156bfcade0d

commit dccb419d713441f745564eadfab23156bfcade0d
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2022-07-06 09:03:32 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2022-07-06 09:04:17 +0000

    app-emulation/virtualbox-guest-additions: respect toolchain env (mostly)
    
    Nearly there but there's some snags with LD. Most of this is syncing
    with vbox.
    
    Bug: https://bugs.gentoo.org/759100
    Closes: https://bugs.gentoo.org/739662
    Signed-off-by: Sam James <sam@gentoo.org>

 .../virtualbox-guest-additions-6.1.34-r2.ebuild    | 272 +++++++++++++++++++++
 1 file changed, 272 insertions(+)
Comment 6 Agostino Sarubbo gentoo-dev 2022-07-06 10:17:30 UTC
ci has reproduced this issue with version 6.1.34-r2 - Updating summary.
Comment 7 Larry the Git Cow gentoo-dev 2022-07-10 22:51:36 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=385399998583db6d847f7efdb1999951eaaf9a68

commit 385399998583db6d847f7efdb1999951eaaf9a68
Author:     Viorel Munteanu <ceamac.paragon@gmail.com>
AuthorDate: 2022-07-10 11:29:47 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2022-07-10 22:50:41 +0000

    app-emulation/virtualbox-guest-additions: respect LDFLAGS
    
    Closes: https://bugs.gentoo.org/759100
    Closes: https://bugs.gentoo.org/854552
    Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com>
    Signed-off-by: Sam James <sam@gentoo.org>

 .../virtualbox-guest-additions-6.1.34-r3.ebuild    | 279 +++++++++++++++++++++
 1 file changed, 279 insertions(+)