Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 759040 - dev-python/pyftpdlib-1.5.6-r1 fails tests with Python >= 3.9.3
Summary: dev-python/pyftpdlib-1.5.6-r1 fails tests with Python >= 3.9.3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL: https://github.com/giampaolo/pyftpdli...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-08 12:50 UTC by Agostino Sarubbo
Modified: 2021-05-11 17:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,196.92 KB, text/plain)
2020-12-08 12:50 UTC, Agostino Sarubbo
Details
build.log (ppc, 1.5.6-r1) (pyftpdlib-1.5.6-r1:20210414-152206.log,106.51 KB, text/plain)
2021-04-14 15:38 UTC, ernsteiswuerfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-12-08 12:50:52 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: dev-python/pyftpdlib-1.5.6-r1 fails tests.
Discovered on: amd64 (internal ref: ci)
Comment 1 Agostino Sarubbo gentoo-dev 2020-12-08 12:50:55 UTC
Created attachment 677230 [details]
build.log

build log and emerge --info
Comment 2 ernsteiswuerfel 2021-04-14 15:38:30 UTC
Created attachment 699822 [details]
build.log (ppc, 1.5.6-r1)

ppc fails 8 tests:

[...]
======================================= short test summary info ========================================
FAILED pyftpdlib/test/test_authorizers.py::TestUnixAuthorizer::test_override_user_password - TypeErro...
FAILED pyftpdlib/test/test_functional.py::TestConfigurableOptions::test_masquerade_address - Assertio...
FAILED pyftpdlib/test/test_functional.py::TestConfigurableOptions::test_masquerade_address_map - Asse...
FAILED pyftpdlib/test/test_functional.py::ThreadedFTPTests::test_permit_privileged_ports - AssertionE...
FAILED pyftpdlib/test/test_functional_ssl.py::TestConfigurableOptions::test_masquerade_address - Asse...
FAILED pyftpdlib/test/test_functional_ssl.py::TestConfigurableOptions::test_masquerade_address_map - ...
FAILED pyftpdlib/test/test_functional_ssl.py::TestConfigurableOptionsTLSMixin::test_masquerade_address
FAILED pyftpdlib/test/test_functional_ssl.py::TestConfigurableOptionsTLSMixin::test_masquerade_address_map
================= 8 failed, 715 passed, 36 skipped, 18 deselected in 62.13s (0:01:02) ==================
Comment 3 Louis Sautier (sbraz) gentoo-dev 2021-04-21 22:22:46 UTC
This is caused by https://bugs.python.org/issue43285 which was fixed in:
- 3.6.14
- 3.7.11
- 3.8.9
- 3.9.3
Comment 4 Larry the Git Cow gentoo-dev 2021-05-11 17:20:48 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=eb4b2b6723a39ac985e7041659c863b0966a841f

commit eb4b2b6723a39ac985e7041659c863b0966a841f
Author:     Louis Sautier <sbraz@gentoo.org>
AuthorDate: 2021-05-11 17:12:07 +0000
Commit:     Louis Sautier <sbraz@gentoo.org>
CommitDate: 2021-05-11 17:20:04 +0000

    dev-python/pyftpdlib: skip more broken tests, use epytest
    
    Closes: https://bugs.gentoo.org/759040
    Signed-off-by: Louis Sautier <sbraz@gentoo.org>

 dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)