Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 75513 - Apps fail to compile, getting sanity check failures.
Summary: Apps fail to compile, getting sanity check failures.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High blocker (vote)
Assignee: Gentoo Toolchain Maintainers
Depends on:
Reported: 2004-12-23 20:38 UTC by Steve
Modified: 2004-12-28 12:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Diffutils config.log (config.log,17.30 KB, text/plain)
2004-12-28 12:15 UTC, Steve

Note You need to log in before you can comment on or make changes to this bug.
Description Steve 2004-12-23 20:38:57 UTC
Trying to emerge anythong on my box fails with a "/lib/cpp fails sanity check" error message.  I just did an emerge sync today about 3 hours ago.

Reproducible: Always
Steps to Reproduce:

Portage 2.0.51-r3 (default-linux/x86/2004.0, gcc-3.3.4, glibc-,
2.6.8-gentoo-r7 i686)
System uname: 2.6.8-gentoo-r7 i686 Pentium II (Klamath)
Gentoo Base System version 1.4.16
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Libtools: sys-devel/libtool-1.5.2-r7
CFLAGS="-march=pentium2 -Os -mmmx -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.1/share/config /usr/kde/3/share/config /usr/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium2 -Os -mmmx -fomit-frame-pointer -pipe"
FEATURES="autoaddcvs autoconfig ccache distcc distlocks sandbox sfperms"
USE="x86 X aalib acl apm arts avi berkdb bitmap-fonts crypt esd fam flac
foomaticdb fortran gdbm gif gpm gtk gtk2 imagemagick imlib ipv6 java jpeg junit
kde libwww mad mikmod motif mpeg ncurses oggvorbis opengl oss pam pdflib perl
png postgres python qt readline ruby samba scanner sdl slang speex spell ssl
svga tcltk tcpd tiff truetype xml2 xv zlib"
Comment 1 SpanKY gentoo-dev 2004-12-24 00:09:01 UTC
you have to post the actual error message

also, you should post a config.log from the build directory

chances are you need to just re-run `gcc-config`
Comment 2 Steve 2004-12-24 08:21:38 UTC
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for i686-pc-linux-gnu-strip... no
checking for strip... strip
checking for style of include used by make... GNU
checking for i686-pc-linux-gnu-gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... /lib/cpp
configure: error: C preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.

!!! ERROR: sys-apps/diffutils-2.8.7 failed.
!!! Function econf, Line 449, Exitcode 1
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.
Comment 3 Steve 2004-12-24 08:23:45 UTC
Also, it's just not diffutils, I get the same error while compiling alsa-libs as well.
Comment 4 Steve 2004-12-28 12:15:55 UTC
Created attachment 47048 [details]
Diffutils config.log
Comment 5 Steve 2004-12-28 12:17:13 UTC
I ran gcc-config -O and I still can not compile anything.
Comment 6 SpanKY gentoo-dev 2004-12-28 12:50:54 UTC
/usr/include/bits/local_lim.h:36:26: linux/limits.h: No such file or directory

looks like the system lost the linux headers at some point

re-emerge virtual/os-headers