Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 755068 - net-dns/https_dns_proxy-0_pre20200925 : error: invalid integral value '32:25:16' in '-falign-functions=32:25:16' [clang-diagnostic-error]
Summary: net-dns/https_dns_proxy-0_pre20200925 : error: invalid integral value '32:25:...
Status: RESOLVED DUPLICATE of bug 755599
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jakov Smolić
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks:
 
Reported: 2020-11-17 13:42 UTC by Toralf Förster
Modified: 2020-11-19 18:25 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.88 KB, text/plain)
2020-11-17 13:42 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,166.96 KB, text/plain)
2020-11-17 13:42 UTC, Toralf Förster
Details
environment (environment,88.64 KB, text/plain)
2020-11-17 13:42 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,15.49 KB, application/x-bzip)
2020-11-17 13:42 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,4.53 KB, application/x-bzip)
2020-11-17 13:42 UTC, Toralf Förster
Details
net-dns:https_dns_proxy-0_pre20200925:20201117-133211.log (net-dns:https_dns_proxy-0_pre20200925:20201117-133211.log,16.40 KB, text/plain)
2020-11-17 13:42 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,24.03 KB, application/x-bzip)
2020-11-17 13:42 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-11-17 13:42:19 UTC
-- Detecting CXX compile features - done
-- clang-tidy found: /usr/lib/llvm/11/bin/clang-tidy
-- Could NOT find GTest (missing: GTEST_LIBRARY GTEST_INCLUDE_DIR GTEST_MAIN_LIBRARY) 
-- <<< Gentoo configuration >>>
Build type      Gentoo
Install path    /usr

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop-libressl-20201113-052431

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-10.2.0 *
clang version 11.0.0
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/11/bin
/usr/lib/llvm/11
11.0.0
Available Python interpreters, in order of preference:
  [1]   python3.7
  [2]   python3.9 (fallback)
  [3]   python3.8 (fallback)
  [4]   python2.7 (fallback)
  [5]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby25 (with Rubygems)
  [2]   ruby26 (with Rubygems)
  [3]   ruby27 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.47.0 *
The following VMs are available for generation-2:
*)	AdoptOpenJDK 8.272_p10 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.8.4

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Tue Nov 17 11:35:32 AM UTC 2020
/var/db/repos/libressl	Sat Nov  7 03:06:11 PM UTC 2020

emerge -qpvO net-dns/https_dns_proxy
[ebuild  N    ] net-dns/https_dns_proxy-0_pre20200925
Comment 1 Toralf Förster gentoo-dev 2020-11-17 13:42:21 UTC
Created attachment 671854 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-11-17 13:42:23 UTC
Created attachment 671857 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-11-17 13:42:24 UTC
Created attachment 671860 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-11-17 13:42:26 UTC
Created attachment 671863 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-11-17 13:42:27 UTC
Created attachment 671866 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-11-17 13:42:28 UTC
Created attachment 671869 [details]
net-dns:https_dns_proxy-0_pre20200925:20201117-133211.log
Comment 7 Toralf Förster gentoo-dev 2020-11-17 13:42:29 UTC
Created attachment 671872 [details]
temp.tbz2
Comment 8 Jakov Smolić gentoo-dev 2020-11-17 13:54:02 UTC
Thanks, will add missing dep shortly
Comment 9 Jakov Smolić gentoo-dev 2020-11-19 18:25:04 UTC
GTest is indeed automagic dep, but this is the same as #755599

*** This bug has been marked as a duplicate of bug 755599 ***