Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 75401 - xine-lib-1-rc8 emerge fails djb_demux_aiff patch
Summary: xine-lib-1-rc8 emerge fails djb_demux_aiff patch
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 75410 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-12-22 21:35 UTC by Josh Joyce
Modified: 2004-12-24 21:35 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
The "new" patch (xine-lib-1_rc8-djb_demux_aiff.patch,538 bytes, patch)
2004-12-23 00:20 UTC, Charlie Gehlin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Josh Joyce 2004-12-22 21:35:32 UTC
I attemped to emerge xine-lib-1_rc8 and got the following error:

>>> emerge (1 of 5) media-libs/xine-lib-1_rc8-r1 to /
>>> md5 src_uri ;-) xine-lib-1-rc8.tar.gz
>>> Unpacking source...
>>> Unpacking xine-lib-1-rc8.tar.gz to /var/tmp/portage/xine-lib-1_rc8-r1/work
 * Applying xine-lib-1_rc7-2.6.patch ...                                  [ ok ] * Applying djb_demux_aiff.patch ...

 * Failed Patch: djb_demux_aiff.patch!
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/xine-lib-1_rc8-r1/temp/djb_demux_aiff.patch-7592.out


The contents of the file mentioned above:

***** djb_demux_aiff.patch *****

================================

PATCH COMMAND:  patch -p0 -g0 < /usr/portage/media-libs/xine-lib/files/djb_demux_aiff.patch

================================
can't find file to patch at input line 8
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|===================================================================
|RCS file: /cvsroot/xine/xine-lib/src/demuxers/demux_aiff.c,v
|retrieving revision 1.39
|retrieving revision 1.40
|diff -u -r1.39 -r1.40
|--- xine/xine-lib/src/demuxers/demux_aiff.c    2004/06/13 21:28:52     1.39
|+++ xine/xine-lib/src/demuxers/demux_aiff.c    2004/12/15 21:03:02     1.40
--------------------------
No file to patch.  Skipping patch.
2 out of 2 hunks ignored
================================

PATCH COMMAND:  patch -p1 -g0 < /usr/portage/media-libs/xine-lib/files/djb_demux_aiff.patch

================================
can't find file to patch at input line 8
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|===================================================================
|RCS file: /cvsroot/xine/xine-lib/src/demuxers/demux_aiff.c,v
|retrieving revision 1.39
|retrieving revision 1.40
|diff -u -r1.39 -r1.40
|--- xine/xine-lib/src/demuxers/demux_aiff.c    2004/06/13 21:28:52     1.39
|+++ xine/xine-lib/src/demuxers/demux_aiff.c    2004/12/15 21:03:02     1.40
--------------------------
No file to patch.  Skipping patch.
2 out of 2 hunks ignored
================================

PATCH COMMAND:  patch -p2 -g0 < /usr/portage/media-libs/xine-lib/files/djb_demux_aiff.patch

================================
patching file src/demuxers/demux_aiff.c
Hunk #1 FAILED at 21.
1 out of 2 hunks FAILED -- saving rejects to file src/demuxers/demux_aiff.c.rej
================================

PATCH COMMAND:  patch -p3 -g0 < /usr/portage/media-libs/xine-lib/files/djb_demux_aiff.patch

================================
can't find file to patch at input line 8
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|===================================================================
|RCS file: /cvsroot/xine/xine-lib/src/demuxers/demux_aiff.c,v
|retrieving revision 1.39
|retrieving revision 1.40
|diff -u -r1.39 -r1.40
|--- xine/xine-lib/src/demuxers/demux_aiff.c    2004/06/13 21:28:52     1.39
|+++ xine/xine-lib/src/demuxers/demux_aiff.c    2004/12/15 21:03:02     1.40
--------------------------
No file to patch.  Skipping patch.
2 out of 2 hunks ignored
================================

PATCH COMMAND:  patch -p4 -g0 < /usr/portage/media-libs/xine-lib/files/djb_demux_aiff.patch

================================
can't find file to patch at input line 8
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|===================================================================
|RCS file: /cvsroot/xine/xine-lib/src/demuxers/demux_aiff.c,v
|retrieving revision 1.39
|retrieving revision 1.40
|diff -u -r1.39 -r1.40
|--- xine/xine-lib/src/demuxers/demux_aiff.c    2004/06/13 21:28:52     1.39
|+++ xine/xine-lib/src/demuxers/demux_aiff.c    2004/12/15 21:03:02     1.40
--------------------------
No file to patch.  Skipping patch.
2 out of 2 hunks ignored


Reproducible: Always
Steps to Reproduce:
1. emerge -u xine-lib
2.
3.

Actual Results:  
The package was not emerged.

Expected Results:  
The package should have been emerged without any trouble.

Portage 2.0.51-r3 (default-linux/x86/2004.3, gcc-3.3.4, glibc-2.3.4.20040808-r1,
2.6.9 i686)
=================================================================
System uname: 2.6.9 i686 AMD Athlon(tm) MP 2600+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.90.0.1.1-r3
Headers:  sys-kernel/linux26-headers-2.6.8.1-r1
Libtools: sys-devel/libtool-1.5.2-r7
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=athlon-mp -fomit-frame-pointer -pipe -mmmx -msse -m3dnow
-mfpmath=sse,387"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-mp -fomit-frame-pointer -pipe -mmmx -msse -m3dnow
-mfpmath=sse,387"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://chod.cwru.edu/gentoo http://gentoo.binarycompass.org
http://www.gigaload.org/gentoo.org/ http://gentoo.seren.com/gentoo"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow X acl adns alsa apm arts avi berkdb bitmap-fonts cdr crypt cups
dvd emacs encode esd fam flac foomaticdb fortran gdbm gif gnome gpm gstreamer
gtk gtk2 imagemagick imlib ipv6 java jpeg junit kde libwww mad mikmod mmx motif
mozilla mpeg ncurses nls oggvorbis opengl oss pam pdflib perl png postgres
python qt quicktime readline sdl spell ssl svg svga tcpd tetex tiff truetype
xine xml2 xmms xv xvid zlib video_cards_nvidia"
Comment 1 Charlie Gehlin 2004-12-23 00:18:14 UTC
Have the same problem but in xine-lib-1_rc8-r1. I copied the patch from files/djb_demux_aiff.patch to files/xine-lib-1_rc8-djb_demux_aiff.patch and removed the top 5 lines and cut out the first chunk (as it does nothing?). Anyway, the patch now reads:
[snip]
--- src/demuxers/demux_aiff.orig        2004/06/13 21:28:52     1.39
+++ src/demuxers/demux_aiff.c   2004/12/15 21:03:02     1.40
@@ -120,6 +120,12 @@
     }
     chunk_type = BE_32(&preamble[0]);
     chunk_size = BE_32(&preamble[4]);
+
+    if (chunk_size > sizeof(buffer) / sizeof(buffer[0])) {
+      /* the chunk is too large to fit in the buffer -> this cannot be an aiff chunk */
+      this->status = DEMUX_FINISHED;
+      return 0;
+    }

     if (chunk_type == COMM_TAG) {
       if (this->input->read(this->input, buffer, chunk_size) !=
[/snip]

And change the ebuild, in this case the rc8, in my case rc8-r1 to read
epatch ${FILESDIR}/xine-lib-1_rc8-djb_demux_aiff.patch

This made the patch insert, but configure later complains:
'configure: error: conditional "HAVE_XV" was never defined.
Usually this means the macro was only invoked conditionally.'
but I think thats another bug# ;)
So edit your ebuild and add the patch to your files-dir and try again.

Thanks!

/
Comment 2 Charlie Gehlin 2004-12-23 00:18:14 UTC
Have the same problem but in xine-lib-1_rc8-r1. I copied the patch from files/djb_demux_aiff.patch to files/xine-lib-1_rc8-djb_demux_aiff.patch and removed the top 5 lines and cut out the first chunk (as it does nothing?). Anyway, the patch now reads:
[snip]
--- src/demuxers/demux_aiff.orig        2004/06/13 21:28:52     1.39
+++ src/demuxers/demux_aiff.c   2004/12/15 21:03:02     1.40
@@ -120,6 +120,12 @@
     }
     chunk_type = BE_32(&preamble[0]);
     chunk_size = BE_32(&preamble[4]);
+
+    if (chunk_size > sizeof(buffer) / sizeof(buffer[0])) {
+      /* the chunk is too large to fit in the buffer -> this cannot be an aiff chunk */
+      this->status = DEMUX_FINISHED;
+      return 0;
+    }

     if (chunk_type == COMM_TAG) {
       if (this->input->read(this->input, buffer, chunk_size) !=
[/snip]

And change the ebuild, in this case the rc8, in my case rc8-r1 to read
epatch ${FILESDIR}/xine-lib-1_rc8-djb_demux_aiff.patch

This made the patch insert, but configure later complains:
'configure: error: conditional "HAVE_XV" was never defined.
Usually this means the macro was only invoked conditionally.'
but I think thats another bug# ;)
So edit your ebuild and add the patch to your files-dir and try again.

Thanks!

/©harlie
Comment 3 Charlie Gehlin 2004-12-23 00:20:49 UTC
Created attachment 46694 [details, diff]
The "new" patch

To put in files-dir.
Comment 4 Charlie Gehlin 2004-12-23 00:26:08 UTC
*** Bug 75410 has been marked as a duplicate of this bug. ***
Comment 5 Josh Joyce 2004-12-23 23:12:34 UTC
I'm marking this as fixed. After an emerge sync, this issue disappeared.
Comment 6 Josh Joyce 2004-12-24 21:35:18 UTC
closing