Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 751943 - net-libs/webkit-gtk fails to build with =dev-libs/icu-68.1
Summary: net-libs/webkit-gtk fails to build with =dev-libs/icu-68.1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: icu-68.1
  Show dependency tree
 
Reported: 2020-10-30 16:40 UTC by Lars Wendler (Polynomial-C)
Modified: 2020-11-26 22:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
webkit-gtk-2.28.4-icu68.patch (webkit-gtk-2.28.4-icu68.patch,5.14 KB, patch)
2020-10-30 16:40 UTC, Lars Wendler (Polynomial-C)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2020-10-30 16:40:24 UTC
Created attachment 669338 [details, diff]
webkit-gtk-2.28.4-icu68.patch

This is just one example how the package fails to build:

FAILED: Source/WTF/wtf/CMakeFiles/WTF.dir/text/icu/UTextProvider.cpp.o
/usr/bin/x86_64-pc-linux-gnu-g++ -DBUILDING_GTK__=1 -DBUILDING_WITH_CMAKE=1 -DBUILDING_WTF -DBWRAP_EXECUTABLE=\"/usr/bin/bwrap\" -DDBUS_PROXY_EXECUTABLE=\"/usr/bin/xdg-dbus-proxy\" -DGETTEXT_PACKAGE=\"WebKit2GTK-4.0\" -DHAVE_CONFIG_H=1 -DJSC_GLIB_API_ENABLED -DSVN_REVISION=\"tarball\" -DWEBKITGTK_API_VERSION_STRING=\"4.0\" -I. -IDerivedSources -I/var/tmp/portage/net-libs/webkit-gtk-2.28.4/work/webkitgtk-2.28.4/Source/ThirdParty -IDerivedSources/WTF -I/var/tmp/portage/net-libs/webkit-gtk-2.28.4/work/webkitgtk-2.28.4/Source/WTF -I/var/tmp/portage/net-libs/webkit-gtk-2.28.4/work/webkitgtk-2.28.4/Source/WTF/wtf -I/var/tmp/portage/net-libs/webkit-gtk-2.28.4/work/webkitgtk-2.28.4/Source/WTF/wtf/dtoa -I/var/tmp/portage/net-libs/webkit-gtk-2.28.4/work/webkitgtk-2.28.4/Source/WTF/wtf/persistence -I/var/tmp/portage/net-libs/webkit-gtk-2.28.4/work/webkitgtk-2.28.4/Source/WTF/wtf/text -I/var/tmp/portage/net-libs/webkit-gtk-2.28.4/work/webkitgtk-2.28.4/Source/WTF/wtf/text/icu -I/var/tmp/portage/net-libs/webkit-gtk-2.28.4/work/webkitgtk-2.28.4/Source/WTF/wtf/threads -I/var/tmp/portage/net-libs/webkit-gtk-2.28.4/work/webkitgtk-2.28.4/Source/WTF/wtf/unicode -IDerivedSources/ForwardingHeaders -isystem /usr/include/gio-unix-2.0 -isystem /usr/include/glib-2.0 -isystem /usr/lib64/glib-2.0/include -isystem /usr/lib64/libffi/include -isystem /usr/include/libmount -isystem /usr/include/blkid  -DNDEBUG -fdiagnostics-color=always -Wextra -Wall -Wno-expansion-to-defined -Wno-noexcept-type -Wno-psabi -Wno-maybe-uninitialized -Wwrite-strings -Wundef -Wpointer-arith -Wmissing-format-attribute -Wformat-security -Wcast-align -march=native -mtune=native -O2 -pipe -fno-strict-aliasing -fno-exceptions -fno-rtti -fPIC -std=c++17 -MD -MT Source/WTF/wtf/CMakeFiles/WTF.dir/text/icu/UTextProvider.cpp.o -MF Source/WTF/wtf/CMakeFiles/WTF.dir/text/icu/UTextProvider.cpp.o.d -o Source/WTF/wtf/CMakeFiles/WTF.dir/text/icu/UTextProvider.cpp.o -c /var/tmp/portage/net-libs/webkit-gtk-2.28.4/work/webkitgtk-2.28.4/Source/WTF/wtf/text/icu/UTextProvider.cpp
In file included from /var/tmp/portage/net-libs/webkit-gtk-2.28.4/work/webkitgtk-2.28.4/Source/WTF/wtf/text/icu/UTextProvider.cpp:27:
/var/tmp/portage/net-libs/webkit-gtk-2.28.4/work/webkitgtk-2.28.4/Source/WTF/wtf/text/icu/UTextProvider.h: In function ‘bool WTF::uTextAccessInChunkOrOutOfRange(UText*, int64_t, int64_t, UBool, UBool&)’:
/var/tmp/portage/net-libs/webkit-gtk-2.28.4/work/webkitgtk-2.28.4/Source/WTF/wtf/text/icu/UTextProvider.h:82:28: error: ‘TRUE’ was not declared in this scope
   82 |             isAccessible = TRUE;
      |                            ^~~~
/var/tmp/portage/net-libs/webkit-gtk-2.28.4/work/webkitgtk-2.28.4/Source/WTF/wtf/text/icu/UTextProvider.h:87:28: error: ‘FALSE’ was not declared in this scope
   87 |             isAccessible = FALSE;
      |                            ^~~~~
/var/tmp/portage/net-libs/webkit-gtk-2.28.4/work/webkitgtk-2.28.4/Source/WTF/wtf/text/icu/UTextProvider.h:96:28: error: ‘TRUE’ was not declared in this scope
   96 |             isAccessible = TRUE;
      |                            ^~~~
/var/tmp/portage/net-libs/webkit-gtk-2.28.4/work/webkitgtk-2.28.4/Source/WTF/wtf/text/icu/UTextProvider.h:101:28: error: ‘FALSE’ was not declared in this scope
  101 |             isAccessible = FALSE;
      |                            ^~~~~
ninja: build stopped: subcommand failed.
Comment 1 Andreas Sturmlechner gentoo-dev 2020-11-26 15:39:55 UTC
ping
Comment 2 Larry the Git Cow gentoo-dev 2020-11-26 22:40:49 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=fd0355d8d21f68237792e427dbe3da433ee66f82

commit fd0355d8d21f68237792e427dbe3da433ee66f82
Author:     Mart Raudsepp <leio@gentoo.org>
AuthorDate: 2020-11-26 22:39:31 +0000
Commit:     Mart Raudsepp <leio@gentoo.org>
CommitDate: 2020-11-26 22:39:44 +0000

    net-libs/webkit-gtk: security bump to 2.30.3
    
    Bug: https://bugs.gentoo.org/755947
    Closes: https://bugs.gentoo.org/751943
    Closes: https://bugs.gentoo.org/751271
    Package-Manager: Portage-2.3.103, Repoman-2.3.20
    Signed-off-by: Mart Raudsepp <leio@gentoo.org>

 net-libs/webkit-gtk/Manifest                 |   1 +
 net-libs/webkit-gtk/files/2.30.3-icu68.patch | 179 ++++++++++++++++
 net-libs/webkit-gtk/metadata.xml             |   1 +
 net-libs/webkit-gtk/webkit-gtk-2.30.3.ebuild | 296 +++++++++++++++++++++++++++
 profiles/arch/sparc/package.use.mask         |   4 +
 5 files changed, 481 insertions(+)