Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 750128 - sci-electronics/fasthenry-3.0.20.07.17 calls ar directly
Summary: sci-electronics/fasthenry-3.0.20.07.17 calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andreas K. Hüttel
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2020-10-19 14:15 UTC by Agostino Sarubbo
Modified: 2020-10-24 15:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,20.26 KB, text/plain)
2020-10-19 14:15 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2020-10-19 14:15:51 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: sci-electronics/fasthenry-3.0.20.07.17 calls ar directly.
Discovered on: amd64 (internal ref: ci)

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different AR implementation (like llvm-ar). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the AR variable to x86_64-pc-linux-gnu-ar.
Comment 1 Agostino Sarubbo gentoo-dev 2020-10-19 14:15:54 UTC
Created attachment 666722 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2020-10-19 14:15:57 UTC
Possible context of error(s):

make[2]: ar: No such file or directory
Comment 3 Larry the Git Cow gentoo-dev 2020-10-24 15:40:21 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=bd3e4d8ba482580f3db048d241aee4c4e65c5c6e

commit bd3e4d8ba482580f3db048d241aee4c4e65c5c6e
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2020-10-24 15:39:28 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2020-10-24 15:40:06 +0000

    sci-electronics/fasthenry: Fix ar
    
    Closes: https://bugs.gentoo.org/750128
    Package-Manager: Portage-3.0.8, Repoman-3.0.2
    Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>

 .../fasthenry/fasthenry-3.0.20.07.17.ebuild            |  3 ++-
 .../fasthenry/files/fasthenry-3.0.20.07.17-ar.patch    | 18 ++++++++++++++++++
 2 files changed, 20 insertions(+), 1 deletion(-)