Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 749032 - media-video/pitivi-2020.09 version bump
Summary: media-video/pitivi-2020.09 version bump
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: PATCH, PullRequest
Depends on: 756298
Blocks: python3.8-compat
  Show dependency tree
 
Reported: 2020-10-14 18:12 UTC by Vasyl Tretiakov
Modified: 2021-08-08 18:16 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Support Python 3.8 (0a3cc054a2c20b59f5aaaaa307de3c9af3c0d270.patch,1.76 KB, patch)
2020-12-23 17:59 UTC, poncho
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vasyl Tretiakov 2020-10-14 18:12:14 UTC
Should we make the latest version 2020.09 released on Sep 30, 2020 available?
Comment 1 Kobboi 2020-10-26 13:45:48 UTC
2020.09.2 was released yesterday
Comment 2 poncho 2020-12-17 09:29:28 UTC
media-video/pitivi-2020.09.2

ERROR - The following hard dependencies are unmet:
==================================================
- Gst version 1.16.2.0 is installed but Pitivi requires at least version 1.17.90
- GES version 1.14.5.0 is installed but Pitivi requires at least version 1.17.90

Therefore, should depend on https://bugs.gentoo.org/756298
Comment 3 poncho 2020-12-23 17:59:01 UTC
Created attachment 679338 [details, diff]
Support Python 3.8

Since a version bump is a bit more complicated because a newer version of media-libs/gstreamer is required... maybe consider backporting:

meson: Support Python 3.8
https://gitlab.gnome.org/GNOME/pitivi/-/commit/0a3cc054a2c20b59f5aaaaa307de3c9af3c0d270
Comment 4 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2021-04-22 07:13:35 UTC
@proxy-maint, this one's a priority as we're lastriting stuff on 2021-05-01.
Comment 5 Nikita Zlobin 2021-04-23 10:09:17 UTC
It's not pitivi-2021 available. I guess if commit for python 3.8 existed before 2021, new release could include it.
Comment 6 Nikita Zlobin 2021-04-23 10:13:00 UTC
Typo, must be: It's now pitivi-2021 available.
(in gnome tarballs)