Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 748456 - sys-apps/portage-3.0.4-r1: wrong dependency written in comment by autounmask
Summary: sys-apps/portage-3.0.4-r1: wrong dependency written in comment by autounmask
Status: UNCONFIRMED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-13 12:23 UTC by Nikita Zlobin
Modified: 2020-10-15 09:53 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
log: emerge --info sys-apps/portage (sys-apps-portage-info.lz,5.68 KB, application/x-lzip)
2020-10-13 12:27 UTC, Nikita Zlobin
Details
output: emerge -tavuDN1 --verbose-conflicts world (emerge.log.lz,61.64 KB, application/x-lzip)
2020-10-13 12:33 UTC, Nikita Zlobin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikita Zlobin 2020-10-13 12:23:45 UTC
I'm in start of standard periodical world rebuild. For now is simple upgrade. I have autounmask on to save time with keywords, and use flag editing.

I got problem with some python packages. Just one example:

# required by dev-python/cffi-1.14.0-r3::gentoo
# required by virtual/python-cffi-1::gentoo[-python_targets_python3_8,python_targets_python3_7,python_targets_python3_6]
# required by dev-python/pycryptodome-3.9.8-r1::gentoo
# required by net-im/gajim-1.2.1::gentoo[python_single_target_python3_7,crypt]
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask/custom.cldx:
#virtual/blas::gentoo
#virtual/cblas::gentoo
#virtual/lapack::gentoo
#sci-libs/lapack-reference::gentoo
#sci-libs/gsl::gentoo
#sci-libs/blas-reference::gentoo
#sci-libs/cblas-reference::gentoo
#app-admin/eselect
#dev-java/icedtea-bin:7
#=media-libs/opencolorio-1.0.9-r4
=dev-python/pycparser-2.20-r2

As you look into ebuilds, dev-python/cffi-1.14.0-r3 doesn't specify minimal version for pycparser, yet it has no python3 support (so no reason to want pycparser-2.20-r2 from overlay).

I'm certain that comment itself doesn't lie, because dev-python/cffi is only installed pycparser dependent.

Reproducible: Always




It happened earlier, though I don't see anything about it among my reports.
Comment 1 Nikita Zlobin 2020-10-13 12:27:48 UTC
Created attachment 665041 [details]
log: emerge --info sys-apps/portage
Comment 2 Nikita Zlobin 2020-10-13 12:33:17 UTC
Created attachment 665044 [details]
output: emerge -tavuDN1 --verbose-conflicts world
Comment 3 Nikita Zlobin 2020-10-13 13:21:54 UTC
I was wrong about exact reason, it's indeed wrong comment.
I did not notice =dev-python/cffi-1.14.3 below.

Here is true reason:
dev-python/cffi:0

  (dev-python/cffi-1.14.0-r3:0/1.14.0::gentoo, ebuild scheduled for merge) USE="-doc -test" ABI_X86="(64)" PYTHON_TARGETS="python3_6 python3_7 -python3_8 (-python3_9)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-python/cffi-1.14.3:0/1.14.3::stefantalpalaru, ebuild scheduled for merge) USE="-doc -test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 -python3_8 (-python3_9)" pulled in by
    >=dev-python/cffi-1.4.1[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pynacl-1.2.1:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -python3_7"
                                                                                                                                                                                                                                                                                                                                                                                                                                                     
    >=dev-python/cffi-1.1:=[python_targets_python2_7(-)?,-python_single_target_python2_7(-),python_targets_python3_6(-)?,-python_single_target_python3_6(-),python_targets_python3_7(-)?,-python_single_target_python3_7(-),python_targets_python3_8(-)?,-python_single_target_python3_8(-),python_targets_python3_9(-)?,-python_single_target_python3_9(-)] required by (dev-python/bcrypt-3.1.7-r3:0/0::stefantalpalaru, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 -python3_8 (-python3_9)"