Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 74310 - Similar to Bug 71360 avifile-0.7.41.20041001-r1 fails to compile
Summary: Similar to Bug 71360 avifile-0.7.41.20041001-r1 fails to compile
Status: RESOLVED DUPLICATE of bug 71360
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-13 11:19 UTC by Erwin Telser
Modified: 2005-07-17 13:06 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erwin Telser 2004-12-13 11:19:59 UTC
/bin/sh ../../../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../../../include   -DHAVE_AV_CONFIG_H -I./.. -Wall -Wno-unused -I../../../include  -march=pentium4 -pipe -fomit-frame-pointer -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE  -msse -c fft_sse.c
dsputil_mmx.c: In function `dsputil_init_mmx':
dsputil_mmx.c:3081: warning: assignment from incompatible pointer type
dsputil_mmx.c:3082: warning: assignment from incompatible pointer type
dsputil_mmx.c: In function `transpose4x4':
dsputil_mmx.c:615: error: can't find a register in class `GENERAL_REGS' while reloading `asm'
make[3]: *** [dsputil_mmx.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
 gcc -DHAVE_CONFIG_H -I. -I. -I../../../include -DHAVE_AV_CONFIG_H -I./.. -Wall -Wno-unused -I../../../include -march=pentium4 -pipe -fomit-frame-pointer -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -msse -c fft_sse.c  -fPIC -DPIC -o .libs/fft_sse.o
make[3]: Leaving directory `/var/tmp/portage/avifile-0.7.41.20041001-r1/work/avifile-0.7-0.7.41/ffmpeg/libavcodec/i386'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/avifile-0.7.41.20041001-r1/work/avifile-0.7-0.7.41/ffmpeg/libavcodec'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/avifile-0.7.41.20041001-r1/work/avifile-0.7-0.7.41/ffmpeg'
make: *** [all-recursive] Error 1

!!! ERROR: media-video/avifile-0.7.41.20041001-r1 failed.
!!! Function src_compile, Line 139, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.

emerge info
Portage 2.0.51-r3 (default-linux/x86/2004.0, gcc-3.3.4, glibc-2.3.4.20040808-r1, 2.6.9-gentoo-r9 i686)
=================================================================
System uname: 2.6.9-gentoo-r9 i686 Intel(R) Pentium(R) 4 CPU 2.00GHz
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.90.0.1.1-r3
Headers:  sys-kernel/linux26-headers-2.6.8.1-r1
Libtools: sys-devel/libtool-1.5.2-r7
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium4 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/      http://ftp.snt.utwente.nl/pub/os/linux/gentooftp://ftp.snt.utwente.nl/pub/os/linux/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acpi alsa apache2 apm arts audiofile avi berkdb bitmap-fonts bonobo cdparanoia cdr crypt cups dga dmx doc dvd encode esd f77 fam flac foomaticdb fortran gdbm gif glx gpm gs gtk gtk2 gtkhtml guile hal imagemagick imlib insecure-drivers java jpeg kde ldap libg++ libwww mad matrox mikmod motif mpeg mpeg4 mplayer mtx, mysql ncurses nls nptl oggvorbis ooo-kde opengl pam pdflib perl png python qt quicktime readline samba scanner sdl slang spell sse sse2 ssl svga tcltk tcpd tiff truetype v4l2 wmf x86 xine xml xml2 xmms xv xvid zlib zvbi video_cards_matrox linguas_sg linguas_de"

Reproducible: Always
Steps to Reproduce:
1.emerge avifile
2.
3.

Actual Results:  
compile stops

Expected Results:  
update of 0.7.41.20041001 to 0.7.41.20041001-r1
Comment 1 Daniel Black (RETIRED) gentoo-dev 2004-12-21 01:07:33 UTC
ditto.
Comment 2 Jim Tupper 2005-02-06 04:10:14 UTC
Same problem here, I've run the fix_libtool_files.sh to death as well, it doesn't appear to be the problem. Has anyone found a workaround at all?
Comment 3 Jim Tupper 2005-02-06 04:20:18 UTC
I get the same problem with -r2 as well :/
Comment 4 Jim Tupper 2005-02-06 05:20:47 UTC
Found a workaround, the following command compiles it ok:
CFLAGS="" emerge ffmpeg avifile

<a href="http://forums.gentoo.org/viewtopic.php?t=253058&highlight=avifile">http://forums.gentoo.org/viewtopic.php?t=253058&highlight=avifile</a>

So is this a cflags issue?
Comment 5 Helge Haugland 2005-02-07 12:03:20 UTC
'CFLAGS="" emerge ffmpeg avifile' didn't do it for me.. 

gcc -Wall  -DHAVE_AV_CONFIG_H -I.. -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -c -o i386/dsputil_mmx.o i386/dsputil_mmx.c
i386/dsputil_mmx.c: In function `h263_h_loop_filter_mmx':
i386/dsputil_mmx.c:634: error: can't find a register in class `GENERAL_REGS' while reloading `asm'
i386/dsputil_mmx.c: In function `dsputil_init_mmx':
i386/dsputil_mmx.c:2540: warning: assignment from incompatible pointer type
i386/dsputil_mmx.c:2541: warning: assignment from incompatible pointer type
make[1]: *** [i386/dsputil_mmx.o] Error 1
make[1]: Leaving directory `/home/tmp/portage/ffmpeg-0.4.9_pre1/work/ffmpeg-0.4.9-pre1/libavcodec'
make: *** [lib] Error 2

!!! ERROR: media-video/ffmpeg-0.4.9_pre1 failed.
Comment 6 Chris White (RETIRED) gentoo-dev 2005-03-22 06:10:40 UTC
[multiple bug change]

avifile 0.7.43 is out.  Please confirm your bugs against it.  Update the topic
if you can confirm it to the new version number.  Thanks :).
Comment 7 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-04-17 18:05:56 UTC
It's not exactly a dupe, but as both bugs refers to internal ffmpeg problems, they probably be better fixed together.
They should also be already fixed by newer avifile.

*** This bug has been marked as a duplicate of 71360 ***